summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/vim.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm27
1 files changed, 9 insertions, 18 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index b2228bed4c..642384adfc 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -156,10 +156,7 @@
(string-append vimdir "/vimrc"))
#t))))))
(inputs
- `(("gawk" ,gawk)
- ("ncurses" ,ncurses)
- ("perl" ,perl)
- ("tcsh" ,tcsh))) ; For runtime/tools/vim32
+ (list gawk ncurses perl tcsh)) ; For runtime/tools/vim32
(native-inputs
`(("libtool" ,libtool)
("guix.vim" ,(search-auxiliary-file "guix.vim"))
@@ -247,9 +244,8 @@ with the editor vim.")))
(zero? (system (string-append xorg-server "/bin/Xvfb "
display " &")))))))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("xorg-server" ,xorg-server-for-tests)
- ,@(package-native-inputs vim)))
+ (modify-inputs (package-native-inputs vim)
+ (prepend pkg-config xorg-server-for-tests)))
(inputs
`(("acl" ,acl)
("atk" ,atk)
@@ -783,11 +779,9 @@ refactor Vim in order to:
(add-before 'build 'set-home
(lambda _ (setenv "HOME" "/tmp"))))))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(inputs
- `(("efl" ,efl)
- ("msgpack" ,msgpack)
- ("neovim" ,neovim)))
+ (list efl msgpack neovim))
(home-page "https://github.com/jeanguyomarch/eovim/")
(synopsis "EFL GUI for Neovim")
(description "Graphical Neovim interface based on the @acronym{EFL, Enlightenment
@@ -839,11 +833,9 @@ and support for fonts with ligatures.")
(delete-file-recursively (string-append vifm "/vim")))
#t)))))
(native-inputs
- `(("groff" ,groff))) ; for the documentation
+ (list groff)) ; for the documentation
(inputs
- `(("libx11" ,libx11)
- ("ncurses" ,ncurses)
- ("perl" ,perl)))
+ (list libx11 ncurses perl))
(home-page "https://vifm.info/")
(synopsis "Flexible vi-like file manager using ncurses")
(description "Vifm is a file manager providing a @command{vi}-like usage
@@ -888,8 +880,7 @@ With the package comes a plugin to use vifm as a vim file selector.")
"13qgwkqbx012j5spis1aw8rb120rw0zphgjy1j58irax8r6j1ikb"))))
(build-system python-build-system)
(propagated-inputs
- `(("python-greenlet" ,python-greenlet)
- ("python-msgpack" ,python-msgpack)))
+ (list python-greenlet python-msgpack))
(arguments
`(#:tests? #f))
(home-page "https://github.com/neovim/pynvim")
@@ -1283,7 +1274,7 @@ additions:
(string-append all "\n"
leader ctags "/bin/ctags']")))))))))
(inputs
- `(("universal-ctags" ,universal-ctags)))
+ (list universal-ctags))
(home-page "https://github.com/preservim/tagbar")
(synopsis "Vim plugin that displays tags in a window, ordered by scope")
(description