summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:52:01 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-08-12 11:56:55 +0300
commit513a66c9329cf3a57c6b225318bb67766da097f7 (patch)
treee337c8e58a773fa8889536df924f0646cd83af87 /gnu/packages/vim.scm
parentb4bd0d86a8824295b9e8f5a89937acf1c132cbdc (diff)
downloadguix-patches-513a66c9329cf3a57c6b225318bb67766da097f7.tar
guix-patches-513a66c9329cf3a57c6b225318bb67766da097f7.tar.gz
gnu: vifm: Re-indent package.
* gnu/packages/vim.scm (vifm)[arguments]: Re-indent section.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm52
1 files changed, 26 insertions, 26 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index 8fc689a79c..1eede0b22a 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -828,32 +828,32 @@ refactor Vim in order to:
"0fyhxh7ndjn8fyjhj14ymkr3pjcs3k1xbs43g7xvvq85vdb6y04r"))))
(build-system gnu-build-system)
(arguments
- '(#:configure-flags '("--disable-build-timestamp")
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'patch-test-shebangs
- (lambda _
- (substitute* (cons* "src/background.c"
- "src/cfg/config.c"
- (find-files "tests" "\\.c$"))
- (("/bin/sh") (which "sh"))
- (("/bin/bash") (which "bash")))
- ;; This test segfaults
- (substitute* "tests/Makefile"
- (("misc") ""))
- #t))
- (add-after 'install 'install-vim-plugin-files
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vifm (string-append out "/share/vifm"))
- (vimfiles (string-append out "/share/vim/vimfiles")))
- (copy-recursively (string-append vifm "/colors")
- (string-append vimfiles "/colors"))
- (copy-recursively (string-append vifm "/vim")
- vimfiles)
- (delete-file-recursively (string-append vifm "/colors"))
- (delete-file-recursively (string-append vifm "/vim")))
- #t)))))
+ '(#:configure-flags '("--disable-build-timestamp")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'patch-source-shebangs 'patch-test-shebangs
+ (lambda _
+ (substitute* (cons* "src/background.c"
+ "src/cfg/config.c"
+ (find-files "tests" "\\.c$"))
+ (("/bin/sh") (which "sh"))
+ (("/bin/bash") (which "bash")))
+ ;; This test segfaults
+ (substitute* "tests/Makefile"
+ (("misc") ""))
+ #t))
+ (add-after 'install 'install-vim-plugin-files
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vifm (string-append out "/share/vifm"))
+ (vimfiles (string-append out "/share/vim/vimfiles")))
+ (copy-recursively (string-append vifm "/colors")
+ (string-append vimfiles "/colors"))
+ (copy-recursively (string-append vifm "/vim")
+ vimfiles)
+ (delete-file-recursively (string-append vifm "/colors"))
+ (delete-file-recursively (string-append vifm "/vim")))
+ #t)))))
(native-inputs
`(("groff" ,groff))) ; for the documentation
(inputs