summaryrefslogtreecommitdiff
path: root/gnu/packages/vim.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-12 11:07:57 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-12 11:16:06 +0300
commit261348e20d25be2e8e4997ceb21811dd821df367 (patch)
tree2be9b727306dea883d9083cef1ddf4c41cf88a17 /gnu/packages/vim.scm
parent35a7e5742fdfad3747078d2e3bef6630f24b2b24 (diff)
downloadguix-patches-261348e20d25be2e8e4997ceb21811dd821df367.tar
guix-patches-261348e20d25be2e8e4997ceb21811dd821df367.tar.gz
gnu: vim-fugitive: Update to 2.3.
* gnu/packages/vim.scm (vim-fugitive): Update to 2.3.
Diffstat (limited to 'gnu/packages/vim.scm')
-rw-r--r--gnu/packages/vim.scm69
1 files changed, 33 insertions, 36 deletions
diff --git a/gnu/packages/vim.scm b/gnu/packages/vim.scm
index fd74b261c6..898a4b3533 100644
--- a/gnu/packages/vim.scm
+++ b/gnu/packages/vim.scm
@@ -450,45 +450,42 @@ trouble using them, because you do not have to remember each snippet name.")
(home-page "https://github.com/Shougo/context_filetype.vim")
(license license:expat)))) ; ??? check again
-;; The 2.2 release was in 2015, no new releases planned.
(define-public vim-fugitive
- (let ((commit "de6c05720cdf74c0218218d7207f700232a5b6dc")
- (revision "1"))
- (package
- (name "vim-fugitive")
- (version (string-append "2.2-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/tpope/vim-fugitive.git")
- (commit commit)))
- (file-name (string-append name "-" version "-checkout"))
- (sha256
- (base32
- "0zg9vv7hirnx45vc2mwgg0xijmwwz55bssyd6cpdz71wbhrcpxxb"))))
- (build-system gnu-build-system)
- (arguments
- '(#:tests? #f
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (delete 'build)
- (replace 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (vimfiles (string-append out "/share/vim/vimfiles"))
- (doc (string-append vimfiles "/doc"))
- (plugin (string-append vimfiles "/plugin")))
- (copy-recursively "doc" doc)
- (copy-recursively "plugin" plugin)
- #t))))))
- (home-page "https://github.com/tpope/vim-fugitive")
- (synopsis "Vim plugin to work with Git")
- (description "Vim-fugitive is a wrapper for Vim that complements the
+ (package
+ (name "vim-fugitive")
+ (version "2.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/tpope/vim-fugitive.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "17s94a8g5z0lrs7yy4nyqyvp9ykys5ws2ar3m3c0bjsn0iazd7m3"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (vimfiles (string-append out "/share/vim/vimfiles"))
+ (doc (string-append vimfiles "/doc"))
+ (plugin (string-append vimfiles "/plugin")))
+ (copy-recursively "doc" doc)
+ (copy-recursively "plugin" plugin)
+ #t))))))
+ (home-page "https://github.com/tpope/vim-fugitive")
+ (synopsis "Vim plugin to work with Git")
+ (description "Vim-fugitive is a wrapper for Vim that complements the
command window, where you can stage and review your changes before the next
commit or run any Git arbitrary command.")
- (license license:vim)))) ; distributed under the same license as vim
+ (license license:vim))) ; distributed under the same license as vim
(define-public vim-airline
(package