summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 22:15:07 +0100
commite3196755e60ba7f1ed9d432e73f26a85e0c8893c (patch)
tree06bc27447f2f72b20a2be0201b41b964af03fc87 /gnu/packages/video.scm
parentfc9ca46aa6403c90e2ea5c815d813d2dba162dfb (diff)
downloadguix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar
guix-patches-e3196755e60ba7f1ed9d432e73f26a85e0c8893c.tar.gz
gnu: Further simplify package inputs.
This is the result of running: ./pre-inst-env guix style --input-simplification=safe and manually undoing changes on a dozen of packages to reduce rebuilds (derivations for emacs, icecat, and libreoffice are unchanged.)
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 16 insertions, 22 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 710c723e85..9b57d3cbb8 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -433,24 +433,22 @@ as a joint effort between the BBC and Fluendo.")
(search-patches "libquicktime-ffmpeg.patch"))))
(build-system gnu-build-system)
(native-inputs
- `(("gettext" ,gettext-minimal)
- ("doxygen" ,doxygen)
- ("pkg-config" ,pkg-config)))
+ (list gettext-minimal doxygen pkg-config))
(inputs
- `(("alsa" ,alsa-lib)
- ("ffmpeg" ,ffmpeg)
- ("gtk+-2" ,gtk+-2)
- ("lame" ,lame)
- ("libdv" ,libdv)
- ("libjpeg" ,libjpeg-turbo)
- ("libpng" ,libpng)
- ("libvorbis" ,libvorbis)
- ("opengl" ,mesa)
- ("schroedinger" ,schroedinger)
- ("x11" ,libx11)
- ("x264" ,libx264)
- ("xaw" ,libxaw)
- ("xv" ,libxv)))
+ (list alsa-lib
+ ffmpeg
+ gtk+-2
+ lame
+ libdv
+ libjpeg-turbo
+ libpng
+ libvorbis
+ mesa
+ schroedinger
+ libx11
+ libx264
+ libxaw
+ libxv))
(synopsis "Quick Time Library")
(description "The goal of this project is to enhance the quicktime4linux
library.")
@@ -516,11 +514,7 @@ receiving MJPG streams.")
(base32 "0kvhxr5hkabj9v7ah2rzkbirndfqdijd9hp8v52c1z6bxddf019w"))))
(build-system gnu-build-system)
(inputs
- `(("gtk+-2" ,gtk+-2)
- ("libdv" ,libdv)
- ("libpng" ,libpng)
- ("libquicktime" ,libquicktime)
- ("sdl" ,sdl)))
+ (list gtk+-2 libdv libpng libquicktime sdl))
(synopsis "Tools for handling MPEG")
(description "Mjpeg tools is a suite of programs which support video capture,
editing, playback, and compression to MPEG of MJPEG video. Edit, play and