summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-06-24 10:00:41 -0400
committerRaghav Gururajan <rg@raghavgururajan.name>2021-07-04 21:07:08 -0400
commite1fb55ab67e35d80da4af84516c086b84f316d58 (patch)
tree9f342c44d4af485261c82ea3b59b3ed93017bb10 /gnu/packages/video.scm
parent88761285cfba437ee649b5092b380b7888c4087a (diff)
downloadguix-patches-e1fb55ab67e35d80da4af84516c086b84f316d58.tar
guix-patches-e1fb55ab67e35d80da4af84516c086b84f316d58.tar.gz
gnu: straw-viewer: Deprecate package.
Upstream has replaced straw-viewer with pipe-viewer. Reference https://github.com/trizen/straw-viewer/commit/dc2dfe82 * gnu/packages/video.scm (straw-viewer): Deprecate in favour of pipe-viewer.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm83
1 files changed, 1 insertions, 82 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index f2c4335079..c02938db08 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1131,88 +1131,7 @@ on the Invidious instances only as a fallback method.")
(license license:artistic2.0)))
(define-public straw-viewer
- (package
- (name "straw-viewer")
- (version "0.1.3")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/trizen/straw-viewer")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "1n21byn7hqykpm94jmmnir1fwsskq6dp9wgj0bd2qf0qx5nq33cl"))))
- (build-system perl-build-system)
- (native-inputs
- `(("perl-module-build" ,perl-module-build)
- ("perl-test-pod" ,perl-test-pod)))
- (inputs
- `(("perl-data-dump" ,perl-data-dump)
- ("perl-json" ,perl-json)
- ("perl-libwww" ,perl-libwww)
- ("perl-lwp-protocol-https" ,perl-lwp-protocol-https)
- ("perl-lwp-useragent-cached" ,perl-lwp-useragent-cached)
- ("perl-mozilla-ca" ,perl-mozilla-ca)
- ("perl-term-readline-gnu" ,perl-term-readline-gnu)
- ("perl-unicode-linebreak" ,perl-unicode-linebreak)
- ("xdg-utils" ,xdg-utils)))
- ;; Required only when building the graphical interface (--gtk).
- ;;("perl-file-sharedir" ,perl-file-sharedir)
-
- ;; Some videos play without youtube-dl, but others silently fail to.
- (propagated-inputs
- `(("youtube-dl" ,youtube-dl)))
- (arguments
- `(#:modules ((guix build perl-build-system)
- (guix build utils)
- (srfi srfi-26))
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'refer-to-inputs
- (lambda* (#:key inputs #:allow-other-keys)
- (substitute* "lib/WWW/StrawViewer.pm"
- (("'youtube-dl'")
- (format #f "'~a/bin/youtube-dl'"
- (assoc-ref inputs "youtube-dl"))))
- (substitute* "bin/gtk-straw-viewer"
- (("'xdg-open'")
- (format #f "'~a/bin/xdg-open'"
- (assoc-ref inputs "xdg-utils"))))
- #t))
- ;; (add-after 'install 'install-desktop
- ;; (lambda* (#:key outputs #:allow-other-keys)
- ;; (let* ((out (assoc-ref outputs "out"))
- ;; (sharedir (string-append out "/share")))
- ;; (install-file "share/gtk-straw-viewer.desktop"
- ;; (string-append sharedir "/applications"))
- ;; (install-file "share/icons/gtk-straw-viewer.png"
- ;; (string-append sharedir "/pixmaps"))
- ;; #t)))
- (add-after 'install 'wrap-program
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin-dir (string-append out "/bin/"))
- (site-dir (string-append out "/lib/perl5/site_perl/"))
- (lib-path (getenv "PERL5LIB")))
- (for-each (cut wrap-program <>
- `("PERL5LIB" ":" prefix (,lib-path ,site-dir)))
- (find-files bin-dir))
- #t))))))
- (synopsis
- "Light-weight application for searching and streaming videos from YouTube")
- (description
- "Straw-viewer searches for YouTube videos using @uref{https://invidio.us/,
-invidio.us} and plays them locally in a native media player like @command{vlc}
-or @command{mpv}.
-
-You can search for videos, playlists, and/or channels. The videos are streamed
-directly to the player at the best chosen resolution and with closed captions if
-available.")
- ;; XXX Add #:module-build-flags '("--gtk") dependencies and this sentence.
- ;; Both a command-line and a graphical interface are available.
- (home-page "https://github.com/trizen/youtube-viewer")
- (license license:perl-license)))
+ (deprecated-package "straw-viewer" pipe-viewer))
(define-public x265
(package