summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-05-30 10:19:50 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-05-30 10:41:28 +0300
commitd56506aad52d6ad757bd04a8559e3ed1411b237e (patch)
tree1047ac47fa87c0a66bac05cf65531814c03e0e9d /gnu/packages/video.scm
parente5dd864e68ee894f207c7c442416d52d120beca0 (diff)
downloadguix-patches-d56506aad52d6ad757bd04a8559e3ed1411b237e.tar
guix-patches-d56506aad52d6ad757bd04a8559e3ed1411b237e.tar.gz
gnu: yt-dlp: Update to 2022.05.18.
* gnu/packages/video.scm (yt-dlp): Update to 2022.05.18. [inputs]: Add python-brotli and python-certifi.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 022c615f49..31e3218320 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2463,7 +2463,7 @@ YouTube.com and many more sites.")
(define-public yt-dlp
(package/inherit youtube-dl
(name "yt-dlp")
- (version "2022.02.04")
+ (version "2022.05.18")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/yt-dlp/yt-dlp/"
@@ -2471,7 +2471,7 @@ YouTube.com and many more sites.")
version "/yt-dlp.tar.gz"))
(sha256
(base32
- "1qx8sx47lzyrcl00r2657zjaq0mwfbzjyfnv5lr5dlm552f13pf8"))
+ "0wiiwqj8m4z6lladmrsp9354ddwlhn2gf0b39j271001g6fyi82r"))
(snippet
'(begin
;; Delete the pre-generated files, except for the man page
@@ -2514,7 +2514,9 @@ YouTube.com and many more sites.")
(when tests?
(invoke "pytest" "-k" "not download"))))))))
(inputs
- `(("python-mutagen" ,python-mutagen)
+ `(("python-brotli" ,python-brotli)
+ ("python-certifi" ,python-certifi)
+ ("python-mutagen" ,python-mutagen)
("python-pycryptodomex" ,python-pycryptodomex)
("python-websockets" ,python-websockets)
,@(package-inputs youtube-dl)))