summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-23 11:22:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-23 11:29:38 +0100
commitb15e543d303ea58fdc0f0541c708389f9d513e3d (patch)
tree5c4bd48d67d4d3cd4806269dcabf58382f448bed /gnu/packages/video.scm
parent4efc08d895274ee39e6e6e5c49121fb05a0281b6 (diff)
parentdaf7b5ecef8de0e536ffd8d2957f022d010767a8 (diff)
downloadguix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar
guix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm42
1 files changed, 40 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index e98e7ceeb8..8b1efa656d 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1076,7 +1076,7 @@ H.264 (MPEG-4 AVC) video streams.")
(define-public pipe-viewer
(package
(name "pipe-viewer")
- (version "0.1.5")
+ (version "0.1.7")
(source
(origin
(method git-fetch)
@@ -1086,7 +1086,7 @@ H.264 (MPEG-4 AVC) video streams.")
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "075xc5kvnmyqqj7zijvdrvbkna931h7xf8f8z0ick7yx5fy3pn5j"))))
+ (base32 "1fh8b77vchpsar88dszsz5h1gzd4jz0v902igp2880vnpvacmfi9"))))
(build-system perl-build-system)
(arguments
`(#:imported-modules
@@ -1425,6 +1425,44 @@ support in old parsers.
libebml is a C++ library to read and write EBML files.")
(license license:lgpl2.1)))
+(define-public libplacebo
+ (package
+ (name "libplacebo")
+ (version "4.157.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://code.videolan.org/videolan/libplacebo")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "08kqsd29h8wm0vz7698wh2mdgpwv6anqc5n7d1spnnamwyfwc64h"))))
+ (build-system meson-build-system)
+ (arguments
+ `(#:configure-flags
+ `("-Dopengl=enabled"
+ ,(string-append "-Dvulkan-registry="
+ (assoc-ref %build-inputs "vulkan-headers")
+ "/share/vulkan/registry/vk.xml"))))
+ (native-inputs
+ `(("python-mako" ,python-mako)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("lcms" ,lcms)
+ ("libepoxy" ,libepoxy)
+ ("mesa" ,mesa)
+ ("shaderc" ,shaderc)
+ ("vulkan-headers" ,vulkan-headers)
+ ("vulkan-loader" ,vulkan-loader)))
+ (home-page "https://code.videolan.org/videolan/libplacebo")
+ (synopsis "GPU-accelerated image/video processing library")
+ (description "libplacebo is, in a nutshell, the core rendering algorithms
+and ideas of mpv rewritten as an independent library. As of today, libplacebo
+contains a large assortment of video processing shaders, focusing on both
+quality and performance.")
+ (license license:lgpl2.1+)))
+
(define-public libva
(package
(name "libva")