summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorRaghav Gururajan <rg@raghavgururajan.name>2021-11-27 05:28:28 -0500
committerRaghav Gururajan <rg@raghavgururajan.name>2021-11-27 05:28:28 -0500
commit96a6084cd8427bd485cea7e3fd0285338faa84ee (patch)
tree5c39ef67cc056d0579fa0acbf364a9340d85e76c /gnu/packages/video.scm
parent6dc682e5b944146c81a1bb13d0ee1493048d2795 (diff)
downloadguix-patches-96a6084cd8427bd485cea7e3fd0285338faa84ee.tar
guix-patches-96a6084cd8427bd485cea7e3fd0285338faa84ee.tar.gz
gnu: pipe-viewer: Correct references to yt-dlp program.
* gnu/packages/video.scm (pipe-viewer)[inputs]: Add yt-dlp. [phases](patch-source): Modify.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 10 insertions, 3 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 0197fff036..8121a72f91 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1106,7 +1106,10 @@ H.264 (MPEG-4 AVC) video streams.")
(substitute* (find-files "lib" "\\.pm$")
(("\"youtube-dl\"")
(format #f "\"~a/bin/youtube-dl\""
- (assoc-ref inputs "youtube-dl"))))
+ (assoc-ref inputs "youtube-dl")))
+ (("\"yt-dlp\"")
+ (format #f "\"~a/bin/yt-dlp\""
+ (assoc-ref inputs "yt-dlp"))))
(substitute* (find-files "bin" ".*-viewer$")
(("'ffmpeg'")
(format #f "'~a/bin/ffmpeg'"
@@ -1119,7 +1122,10 @@ H.264 (MPEG-4 AVC) video streams.")
(assoc-ref inputs "xdg-utils")))
(("'youtube-dl'")
(format #f "'~a/bin/youtube-dl'"
- (assoc-ref inputs "youtube-dl"))))))
+ (assoc-ref inputs "youtube-dl")))
+ (("'yt-dlp'")
+ (format #f "'~a/bin/yt-dlp'"
+ (assoc-ref inputs "yt-dlp"))))))
(add-after 'install 'install-xdg
(lambda args
(apply (assoc-ref copy:%standard-phases 'install)
@@ -1172,7 +1178,8 @@ H.264 (MPEG-4 AVC) video streams.")
("perl-uri-escape" ,perl-uri-escape)
("wget" ,wget)
("xdg-utils" ,xdg-utils)
- ("youtube-dl" ,youtube-dl)))
+ ("youtube-dl" ,youtube-dl)
+ ("yt-dlp" ,yt-dlp)))
(propagated-inputs
`(("dconf" ,dconf)))
(home-page "https://github.com/trizen/pipe-viewer")