summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-12 13:49:47 +0100
committerMarius Bakke <marius@gnu.org>2021-12-12 23:26:02 +0100
commit869d69ad3248288ffe30264f5e5bd760792ca758 (patch)
treeb760b41db2279aee87eb363afe34effaac9d2dc4 /gnu/packages/video.scm
parentdd5851e0880f801ab425483196c30c94af762082 (diff)
downloadguix-patches-869d69ad3248288ffe30264f5e5bd760792ca758.tar
guix-patches-869d69ad3248288ffe30264f5e5bd760792ca758.tar.gz
gnu: gaupol: Don't attempt to compile bytecode twice.
* gnu/packages/video.scm (gaupol)[arguments]: Disable needless compilation with a substitution. While here, remove trailing #t's.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm13
1 files changed, 9 insertions, 4 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index da8dab56b1..eec88195c7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5057,6 +5057,13 @@ video from a Wayland session.")
`(#:tests? #f ; Tests seem to require networking.
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'disable-builtin-byte-compilation
+ (lambda _
+ ;; The setup.py script attempts to compile bytecode and fails.
+ ;; We compile bytecode in a separate phase, so just disable it.
+ (substitute* "setup.py"
+ (("distutils\\.util\\.byte_compile\\(.*")
+ ""))))
;; gaupol's setup.py script does not support one of the Python build
;; system's default flags, "--single-version-externally-managed".
(replace 'install
@@ -5071,8 +5078,7 @@ video from a Wayland session.")
(gi-typelib-path (getenv "GI_TYPELIB_PATH")))
(wrap-program (string-append out "/bin/gaupol")
`("GST_PLUGIN_SYSTEM_PATH" ":" prefix (,gst-plugin-path))
- `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))
- #t))
+ `("GI_TYPELIB_PATH" ":" prefix (,gi-typelib-path))))))
(add-after 'unpack 'patch-data-dir
;; Fix some path variables that setup.py seems to garble.
(lambda* (#:key outputs #:allow-other-keys)
@@ -5081,8 +5087,7 @@ video from a Wayland session.")
(("DATA_DIR = \\{!r\\}\"\\.format\\(data_dir\\)")
(string-append "DATA_DIR = '" out "/share/gaupol'\""))
(("LOCALE_DIR = \\{!r\\}\"\\.format\\(locale_dir\\)")
- (string-append "LOCALE_DIR = '" out "/share/locale'\"")))
- #t))))))
+ (string-append "LOCALE_DIR = '" out "/share/locale'\"")))))))))
(synopsis "Editor for text-based subtitles")
(description
"Gaupol supports multiple subtitle file formats and provides means of