summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2021-12-18 18:12:27 +0000
committerLeo Famulari <leo@famulari.name>2021-12-26 18:36:48 -0500
commit4e9895b462a004ac69ee92f544fe39b6c42d8525 (patch)
treeaf0cc609354616b08a430ca005f98170dd7866a8 /gnu/packages/video.scm
parentbc74c191df789ff200da6f81c3cf599eae39ca8e (diff)
downloadguix-patches-4e9895b462a004ac69ee92f544fe39b6c42d8525.tar
guix-patches-4e9895b462a004ac69ee92f544fe39b6c42d8525.tar.gz
gnu: shotcut: Adjust environment variables in 'wrap-program.
* gnu/packages/video.scm (shotcut)[arguments]<#:phases>: In the 'wrap-program phase, wrap LADSPA_PATH, don't wrap MLT_PREFIX, remove trailing slash from FREI0R_PATH, remove ffmpeg and add mlt to PATH. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index fa8dadb217..3e644ec155 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4846,18 +4846,19 @@ transitions, and effects and then export your film to many common formats.")
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
(frei0r (assoc-ref inputs "frei0r-plugins"))
- (ffmpeg (assoc-ref inputs "ffmpeg"))
(jack (assoc-ref inputs "jack"))
+ (ladspa (assoc-ref inputs "ladspa"))
+ (mlt (assoc-ref inputs "mlt"))
(sdl2 (assoc-ref inputs "sdl2")))
(wrap-program (string-append out "/bin/shotcut")
- `("PATH" ":" prefix
- ,(list (string-append ffmpeg "/bin")))
+ `("FREI0R_PATH" ":" =
+ (,(string-append frei0r "/lib/frei0r-1")))
+ `("LADSPA_PATH" ":" =
+ (,(string-append ladspa "/lib/ladspa")))
`("LD_LIBRARY_PATH" ":" prefix
,(list (string-append jack "/lib" ":" sdl2 "/lib")))
- `("FREI0R_PATH" ":" =
- (,(string-append frei0r "/lib/frei0r-1/")))
- `("MLT_PREFIX" ":" =
- (,(assoc-ref inputs "mlt"))))))))))
+ `("PATH" ":" prefix
+ ,(list (string-append mlt "/bin"))))))))))
(native-inputs
`(("pkg-config" ,pkg-config)
("python-wrapper" ,python-wrapper)