summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-11-27 22:30:53 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-11-28 12:30:42 +0200
commit4632e7c787a0792b4d73fc5c43f7498f4b5e5e06 (patch)
treece0bdcbc3184236f049ecae805e5004de650b486 /gnu/packages/video.scm
parent3c526173ddb072e031429a4c93dc3318188e8f8b (diff)
downloadguix-patches-4632e7c787a0792b4d73fc5c43f7498f4b5e5e06.tar
guix-patches-4632e7c787a0792b4d73fc5c43f7498f4b5e5e06.tar.gz
gnu: avidemux: Clean up inputs.
* gnu/packages/video.scm (avidemux)[inputs]: Remove sdl. Move perl, python-wrapper, qttools, yasm ... [native-inputs]: ... to here. [arguments]: Remove references to sdl.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm14
1 files changed, 5 insertions, 9 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 9836f67386..fb8b0a651f 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1943,7 +1943,11 @@ for use with HTML5 video.")
(patches (search-patches "avidemux-install-to-lib.patch"))))
(build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("qttools" ,qttools)
+ ("yasm" ,yasm)))
;; FIXME: Once packaged, add libraries not found during the build.
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -1958,14 +1962,9 @@ for use with HTML5 video.")
("libvorbis" ,libvorbis)
("libvpx" ,libvpx)
("libxv" ,libxv)
- ("perl" ,perl)
("pulseaudio" ,pulseaudio)
- ("python" ,python-wrapper)
("qtbase" ,qtbase)
- ("qttools" ,qttools)
- ("sdl" ,sdl)
("sqlite" ,sqlite)
- ("yasm" ,yasm)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no check target
@@ -2002,7 +2001,6 @@ for use with HTML5 video.")
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib"))
(top (getcwd))
- (sdl (assoc-ref inputs "sdl"))
(build_component
(lambda* (component srcdir #:optional (args '()))
(let ((builddir (string-append "build_" component)))
@@ -2015,8 +2013,6 @@ for use with HTML5 video.")
(string-append "-DCMAKE_SHARED_LINKER_FLAGS="
"\"-Wl,-rpath=" lib "\"")
(string-append "-DAVIDEMUX_SOURCE_DIR=" top)
- (string-append "-DSDL_INCLUDE_DIR="
- sdl "/include/SDL")
(string-append "../" srcdir)
"-DENABLE_QT5=True"
args)