summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 02:55:30 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-07 05:57:52 +0100
commit386eeb04fadc2e0ebe79fdd5c9aa855132d996b4 (patch)
tree6e68640ace7fd33973dbfb7510b6e2f15e474477 /gnu/packages/video.scm
parent046322189b62981fca6baab4e758e6878eab0758 (diff)
downloadguix-patches-386eeb04fadc2e0ebe79fdd5c9aa855132d996b4.tar
guix-patches-386eeb04fadc2e0ebe79fdd5c9aa855132d996b4.tar.gz
gnu: youtube-dl: Update to 2021.12.17.
* gnu/packages/video.scm (youtube-dl): Update to 2021.12.17. [source, arguments]: Don't explicitly return #t from snippet or phases.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm16
1 files changed, 6 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 23d104aec5..d6b725de4e 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2332,14 +2332,14 @@ To load this plugin, specify the following option when starting mpv:
(define-public youtube-dl
(package
(name "youtube-dl")
- (version "2021.06.06")
+ (version "2021.12.17")
(source (origin
(method url-fetch)
(uri (string-append "https://youtube-dl.org/downloads/latest/"
"youtube-dl-" version ".tar.gz"))
(sha256
(base32
- "1hqan9h55x9gfdakw554vic68w9gpvhblchwxlw265zxp56hxjrw"))
+ "1prm84ci1n1kjzhikhrsbxbgziw6br822psjnijm2ibqnz49jfwz"))
(snippet
'(begin
;; Delete the pre-generated files, except for the man page
@@ -2349,8 +2349,7 @@ To load this plugin, specify the following option when starting mpv:
;;"youtube-dl.1"
"youtube-dl.bash-completion"
"youtube-dl.fish"
- "youtube-dl.zsh"))
- #t))))
+ "youtube-dl.zsh"))))))
(build-system python-build-system)
(arguments
;; The problem here is that the directory for the man page and completion
@@ -2369,8 +2368,7 @@ To load this plugin, specify the following option when starting mpv:
;; Continue respecting the --ffmpeg-location argument.
(substitute* "youtube_dl/postprocessor/ffmpeg.py"
(("\\.get\\('ffmpeg_location'\\)" match)
- (format #f "~a or '~a'" match (which "ffmpeg"))))
- #t))
+ (format #f "~a or '~a'" match (which "ffmpeg"))))))
(add-before 'build 'build-generated-files
(lambda _
;; Avoid the make targets that require pandoc.
@@ -2393,8 +2391,7 @@ To load this plugin, specify the following option when starting mpv:
(("'etc/")
(string-append "'" prefix "/etc/"))
(("'share/")
- (string-append "'" prefix "/share/")))
- #t)))
+ (string-append "'" prefix "/share/"))))))
(add-after 'install 'install-completion
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -2402,8 +2399,7 @@ To load this plugin, specify the following option when starting mpv:
"/share/zsh/site-functions")))
(mkdir-p zsh)
(copy-file "youtube-dl.zsh"
- (string-append zsh "/_youtube-dl"))
- #t))))))
+ (string-append zsh "/_youtube-dl"))))))))
(native-inputs
(list zip))
(inputs