summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-11-28 16:47:01 +0100
commit34f849a945d25daa76d93839dcf8768c8b45b636 (patch)
tree33cde8cf068593f29366ba3702aabdb75b5fa126 /gnu/packages/video.scm
parent0897ad7fac04fc9d814e83eed46e88c7bf9740bc (diff)
parentc09f598d94af81f326fe1d4cf2ab344d4e720679 (diff)
downloadguix-patches-34f849a945d25daa76d93839dcf8768c8b45b636.tar
guix-patches-34f849a945d25daa76d93839dcf8768c8b45b636.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 7 insertions, 11 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2ed4ed2dc1..c93531b744 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1266,7 +1266,8 @@ streaming protocols.")
(build-system gnu-build-system)
;; FIXME: Add additional inputs once available.
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("pkg-config" ,pkg-config)
+ ("yasm" ,yasm)))
(inputs
`(("alsa-lib" ,alsa-lib)
("cdparanoia" ,cdparanoia)
@@ -1297,7 +1298,6 @@ streaming protocols.")
("python" ,python-wrapper)
("sdl" ,sdl)
("speex" ,speex)
- ("yasm" ,yasm)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no test target
@@ -1943,7 +1943,11 @@ for use with HTML5 video.")
(patches (search-patches "avidemux-install-to-lib.patch"))))
(build-system cmake-build-system)
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ `(("perl" ,perl)
+ ("pkg-config" ,pkg-config)
+ ("python" ,python-wrapper)
+ ("qttools" ,qttools)
+ ("yasm" ,yasm)))
;; FIXME: Once packaged, add libraries not found during the build.
(inputs
`(("alsa-lib" ,alsa-lib)
@@ -1958,14 +1962,9 @@ for use with HTML5 video.")
("libvorbis" ,libvorbis)
("libvpx" ,libvpx)
("libxv" ,libxv)
- ("perl" ,perl)
("pulseaudio" ,pulseaudio)
- ("python" ,python-wrapper)
("qtbase" ,qtbase)
- ("qttools" ,qttools)
- ("sdl" ,sdl)
("sqlite" ,sqlite)
- ("yasm" ,yasm)
("zlib" ,zlib)))
(arguments
`(#:tests? #f ; no check target
@@ -2002,7 +2001,6 @@ for use with HTML5 video.")
(let* ((out (assoc-ref outputs "out"))
(lib (string-append out "/lib"))
(top (getcwd))
- (sdl (assoc-ref inputs "sdl"))
(build_component
(lambda* (component srcdir #:optional (args '()))
(let ((builddir (string-append "build_" component)))
@@ -2015,8 +2013,6 @@ for use with HTML5 video.")
(string-append "-DCMAKE_SHARED_LINKER_FLAGS="
"\"-Wl,-rpath=" lib "\"")
(string-append "-DAVIDEMUX_SOURCE_DIR=" top)
- (string-append "-DSDL_INCLUDE_DIR="
- sdl "/include/SDL")
(string-append "../" srcdir)
"-DENABLE_QT5=True"
args)