summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-12-04 20:12:41 +0100
commit33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f (patch)
tree79ee86a29266d0a32ec0d0aa790ee5904b1098b8 /gnu/packages/video.scm
parent936aa05209402dd399869ffae188db5dd5f67d69 (diff)
parentd733a469d74f74734825f1ce777956fb4cac5534 (diff)
downloadguix-patches-33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f.tar
guix-patches-33b59c1a3edbb81735e8d4e977b107f3ba1c2f9f.tar.gz
Merge branch 'staging'
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7b56d8e460..bcb42387e7 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -2343,17 +2343,18 @@ and JACK.")
(define-public libvdpau
(package
(name "libvdpau")
- (version "1.2")
+ (version "1.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://gitlab.freedesktop.org/vdpau/libvdpau"
- "/uploads/14b620084c027d546fa0b3f083b800c6/"
- "libvdpau-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.freedesktop.org/vdpau/libvdpau.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "01ps6g6p6q7j2mjm9vn44pmzq3g75mm7mdgmnhb1qkjjdwc9njba"))))
- (build-system gnu-build-system)
+ "1fb1nh5apr9kzx9bm2lysjwpyva1s60b2l2p230nqgvb11q25hd2"))))
+ (build-system meson-build-system)
(native-inputs
`(("pkg-config" ,pkg-config)))
(inputs