summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorDavid Wilson <david@daviwil.com>2021-02-18 14:34:25 -0800
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-27 12:50:37 +0100
commit2c9a4c9a491ee3863d4540ed64788e654517424f (patch)
treed08760ed71a785af428f795b55a451faa1621bb2 /gnu/packages/video.scm
parent652861139fd92a5f8e55350c3d6286d9d8776ac3 (diff)
downloadguix-patches-2c9a4c9a491ee3863d4540ed64788e654517424f.tar
guix-patches-2c9a4c9a491ee3863d4540ed64788e654517424f.tar.gz
gnu: Add obs-websocket.
* gnu/packages/video.scm (obs-websocket): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 86defcb239..f083df1d65 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -49,6 +49,7 @@
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2021 Alexey Abramov <levenson@mmer.org>
;;; Copyright © 2021 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2021 David Wilson <david@daviwil.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3175,6 +3176,43 @@ and JACK.")
OBS audio sources.")
(license license:gpl2)))
+(define-public obs-websocket
+ (package
+ (name "obs-websocket")
+ (version "4.9.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Palakis/obs-websocket")
+ (commit version)
+ (recursive? #t)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1r47861ma1s3998clahbnbc216wcf706b1ps514k5p28h511l5w0"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no tests
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-permission-change
+ (lambda* _
+ (substitute* "CMakeLists.txt"
+ ;; Remove lines that set writeable permissions on outputs.
+ (("set\\(CMAKE_INSTALL_DEFAULT_DIRECTORY_PERMISSIONS") "")
+ (("OWNER_READ.*\\)") "")
+ (("PERMISSIONS") ")"))
+ #t)))))
+ (inputs
+ `(("obs" ,obs)
+ ("qtbase" ,qtbase)))
+ (home-page "https://github.com/Palakis/obs-websocket")
+ (synopsis "OBS plugin for remote control via WebSockets")
+ (description "This OBS plugin allows you to establish a WebSocket channel
+from within your running OBS instance so that you can control it remotely from
+programs on your current machine or on other machines.")
+ (license license:gpl2+)))
+
(define-public obs-wlrobs
(package
(name "obs-wlrobs")