summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorMarius Bakke <marius@gnu.org>2021-12-12 13:47:42 +0100
committerMarius Bakke <marius@gnu.org>2021-12-12 23:26:01 +0100
commit2ac8a13a6a1c816ccf40da378e49e470cc72203d (patch)
tree5f9538cbf0d88b987cd44db6cb8356ca98a5e3c2 /gnu/packages/video.scm
parent9896e828cae050f9c08a850caf184fdd2c3ced3f (diff)
downloadguix-patches-2ac8a13a6a1c816ccf40da378e49e470cc72203d.tar
guix-patches-2ac8a13a6a1c816ccf40da378e49e470cc72203d.tar.gz
gnu: smplayer: Remove reference to %outputs.
...which no longer exists in qt-build-system. * gnu/packages/video.scm (smplayer)[arguments]: Turn into gexp. Use #$OUTPUT instead of %OUTPUTS. Remove trailing #true's.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm57
1 files changed, 28 insertions, 29 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 7868b5c6fb..23128efc70 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -22,7 +22,7 @@
;;; Copyright © 2017 Gregor Giesen <giesen@zaehlwerk.net>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2018 Roel Janssen <roel@gnu.org>
-;;; Copyright © 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
+;;; Copyright © 2018, 2019, 2020, 2021 Marius Bakke <marius@gnu.org>
;;; Copyright © 2018, 2019, 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018, 2019, 2020 Leo Famulari <leo@famulari.name>
;;; Copyright © 2018 Brendan Tildesley <mail@brendan.scot>
@@ -80,6 +80,7 @@
#:use-module (guix utils)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module (guix gexp)
#:use-module (guix git-download)
#:use-module (guix svn-download)
#:use-module (guix hg-download)
@@ -2247,34 +2248,32 @@ projects while introducing many more.")
("zlib" ,zlib)
("mpv" ,mpv)))
(arguments
- `(#:tests? #false ; no tests
- #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
- (string-append "CC=" ,(cc-for-target))
- ;; A KLUDGE to turn off invoking lrelease on the
- ;; project for now, because it fails consistently
- ;; with "WARNING: Could not find qmake spec
- ;; 'default'". See below.
- "LRELEASE=true")
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- ;; Due to the above, we must run lrelease separately on each .ts file
- ;; (as opposed to running `lrelease-pro smplayer.pro` for the entire
- ;; project, as the Makefile does normally without the above kludge).
- (add-after 'build 'compile-ts-files
- (lambda _
- (for-each (lambda (file)
- (invoke "lrelease" file))
- (find-files "./" "\\.ts$"))
- #true))
- (add-after 'install 'wrap-executable
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (mpv (assoc-ref inputs "mpv")))
- (wrap-program (string-append out "/bin/smplayer")
- `("PATH" ":" prefix
- ,(list (string-append mpv "/bin")))))
- #true)))))
+ (list #:tests? #false ; no tests
+ #:make-flags #~(list (string-append "PREFIX=" #$output)
+ (string-append "CC=" #+(cc-for-target))
+ ;; A KLUDGE to turn off invoking lrelease on the
+ ;; project for now, because it fails consistently
+ ;; with "WARNING: Could not find qmake spec
+ ;; 'default'". See below.
+ "LRELEASE=true")
+ #:phases
+ #~(modify-phases %standard-phases
+ (delete 'configure)
+ ;; Due to the above, we must run lrelease separately on each .ts file
+ ;; (as opposed to running `lrelease-pro smplayer.pro` for the entire
+ ;; project, as the Makefile does normally without the above kludge).
+ (add-after 'build 'compile-ts-files
+ (lambda _
+ (for-each (lambda (file)
+ (invoke "lrelease" file))
+ (find-files "./" "\\.ts$"))))
+ (add-after 'install 'wrap-executable
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (mpv (assoc-ref inputs "mpv")))
+ (wrap-program (string-append out "/bin/smplayer")
+ `("PATH" ":" prefix
+ ,(list (string-append mpv "/bin"))))))))))
(home-page "https://www.smplayer.info")
(synopsis "Complete front-end for MPlayer, a media player")
(description "SMPlayer is a graphical user interface (GUI) for