summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-12-19 17:31:49 -0500
committerLeo Famulari <leo@famulari.name>2021-12-19 17:34:07 -0500
commit0f4c68ecc83189f8f2e557445e4a2da384139d17 (patch)
treeb2a91a239be27ba83ae9a1ebb628fe2bcc5ef4af /gnu/packages/video.scm
parent9b38d9b3b34edb55f7f42b72a611b39e5164cf9f (diff)
downloadguix-patches-0f4c68ecc83189f8f2e557445e4a2da384139d17.tar
guix-patches-0f4c68ecc83189f8f2e557445e4a2da384139d17.tar.gz
gnu: video-contact-sheet: Use the new style.
* gnu/packages/video.scm (video-contact-sheet)[arguments]: Use the new style.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 39ff8a1ffc..7c4410fe12 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -5478,20 +5478,18 @@ elementary stream are provided.")
#:make-flags
#~(list (string-append "prefix=" #$output))
#:phases
- '(modify-phases %standard-phases
+ #~(modify-phases %standard-phases
(delete 'configure)
(delete 'build)
(delete 'check)
(add-after 'install 'wrap-program
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((vcs (string-append (assoc-ref outputs "out") "/bin/vcs"))
- (ffmpeg (assoc-ref inputs "ffmpeg"))
- (imagemagick (assoc-ref inputs "imagemagick")))
- (wrap-program vcs
- `("PATH" ":" prefix
- ,(map (lambda (dir)
- (string-append dir "/bin"))
- (list ffmpeg imagemagick))))))))))
+ (lambda _
+ (wrap-program (string-append #$output "/bin/vcs")
+ `("PATH" ":" prefix
+ ,(map (lambda (dir)
+ (string-append dir "/bin"))
+ (list #$(this-package-input "ffmpeg")
+ #$(this-package-input "imagemagick"))))))))))
(inputs
(list bash-minimal ffmpeg imagemagick))
(synopsis "Create contact sheets (preview images) from videos")