summaryrefslogtreecommitdiff
path: root/gnu/packages/video.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2021-10-22 15:14:24 -0400
committerLeo Famulari <leo@famulari.name>2021-11-01 10:09:28 -0400
commit0cfc13104f0cb9251b6bd4b997e675ae9f03cd85 (patch)
treece05a5088db653a25c1f8d57aab7554f60568245 /gnu/packages/video.scm
parent7eaacf0ece04e10a9f618893222c94b11216227c (diff)
downloadguix-patches-0cfc13104f0cb9251b6bd4b997e675ae9f03cd85.tar
guix-patches-0cfc13104f0cb9251b6bd4b997e675ae9f03cd85.tar.gz
gnu: OpenShot: Update to 2.6.1.
* gnu/packages/video.scm (openshot): Update to 2.6.1. [arguments]: Add a 'fix-symbolic-link' phase to work around a broken symlink. Run the custom 'check' phase when tests? are enabled.
Diffstat (limited to 'gnu/packages/video.scm')
-rw-r--r--gnu/packages/video.scm17
1 files changed, 12 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 6ed49ce5a5..7bf9191811 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4724,7 +4724,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(define-public openshot
(package
(name "openshot")
- (version "2.5.1")
+ (version "2.6.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -4733,7 +4733,7 @@ API. It includes bindings for Python, Ruby, and other languages.")
(file-name (git-file-name name version))
(sha256
(base32
- "0qc5i0ay6j2wab1whl41sjb71cj02pg6y79drf7asrprq8b2rmfq"))
+ "0pa8iwl217503bjlqg2zlrw5lxyq5hvxrf5apxrh3843hj1w1myv"))
(modules '((guix build utils)))
(snippet
'(begin
@@ -4758,9 +4758,10 @@ API. It includes bindings for Python, Ruby, and other languages.")
#:phases (modify-phases %standard-phases
(delete 'build) ;install phase does all the work
(replace 'check
- (lambda _
- (setenv "QT_QPA_PLATFORM" "offscreen")
- (invoke "python" "src/tests/query_tests.py")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "QT_QPA_PLATFORM" "offscreen")
+ (invoke "python" "src/tests/query_tests.py"))))
(add-after 'unpack 'patch-font-location
(lambda* (#:key inputs #:allow-other-keys)
(let ((font (assoc-ref inputs "font-dejavu")))
@@ -4769,6 +4770,12 @@ API. It includes bindings for Python, Ruby, and other languages.")
(("fonts") "share/fonts/truetype")
(("[A-Za-z_-]+.ttf") "DejaVuSans.ttf")))
#t))
+ ;; https://github.com/OpenShot/openshot-qt/issues/4502
+ (add-before 'ensure-no-mtimes-pre-1980 'fix-symbolic-link
+ (lambda _
+ (delete-file "images/Humanity/actions/custom/razor_line_with_razor.png")
+ (symlink "../../../../src/timeline/media/images/razor_line_with_razor.png"
+ "images/Humanity/actions/custom/razor_line_with_razor.png")))
(add-before 'install 'set-tmp-home
(lambda _
;; src/classes/info.py "needs" to create several