summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-19 08:50:35 +0100
commitdd0568a77951804d97884a0a0a3a3ed38ca0a184 (patch)
tree75b5bfcb64e0e3477a725a93ed85eda327c52d44 /gnu/packages/version-control.scm
parent142cd4dc98ed439f32d2a903ff866ae345234c0f (diff)
parentbaab9eef27994575e3ce1ba7efb822725600f748 (diff)
downloadguix-patches-dd0568a77951804d97884a0a0a3a3ed38ca0a184.tar
guix-patches-dd0568a77951804d97884a0a0a3a3ed38ca0a184.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index c0f8130de4..ac2a849705 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -154,14 +154,14 @@ as well as the classic centralized workflow.")
(name "git")
;; XXX When updating Git, check if the special 'git-source' input to cgit
;; needs to be updated as well.
- (version "2.25.1")
+ (version "2.25.2")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "09lzwa183nblr6l8ib35g2xrjf9wm9yhk3szfvyzkwivdv69c9r2"))))
+ "08vivrv3my8nlp40pwsf7mcc5k7dwyh34hadjszx7qj8w01p34wv"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -178,7 +178,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "15pfm7j4wq8ryp9n9d81h8v0arl15yq9i6cigw45walnq5r6721h"))))
+ "06nlw6vaqvavkr4nia9qvanqbhaig4hbg9r5f0i9lbvw1hmykfvq"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)
@@ -239,9 +239,6 @@ as well as the classic centralized workflow.")
#:test-target "test"
- ;; Tests fail randomly when parallel: <https://bugs.gnu.org/29512>.
- #:parallel-tests? #f
-
;; The explicit --with-tcltk forces the build system to hardcode the
;; absolute file name to 'wish'.
#:configure-flags (list (string-append "--with-tcltk="