summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorGreg Hogan <code@greghogan.com>2020-12-31 18:18:11 +0000
committerLeo Famulari <leo@famulari.name>2021-01-01 17:12:52 -0500
commitce3b439ae7c6dcc1f0cc334fa1c6a783854ec761 (patch)
treeac09dde5f6441a09f59baf9206f06b495cb913d2 /gnu/packages/version-control.scm
parent05c37c53c7308732f4f43d894195a0c296db4439 (diff)
downloadguix-patches-ce3b439ae7c6dcc1f0cc334fa1c6a783854ec761.tar
guix-patches-ce3b439ae7c6dcc1f0cc334fa1c6a783854ec761.tar.gz
gnu: git: Update to 2.30.0.
* gnu/packages/version-control.scm (git): Update to 2.30.0. (native-inputs)[git-manpages]: Update hash. Signed-off-by: Leo Famulari <leo@famulari.name>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d20cf7e655..b57b0320b0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -32,6 +32,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Tanguy Le Carrour <tanguy@bioneland.org>
;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2021 Greg Hogan <code@greghogan.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -163,14 +164,14 @@ as well as the classic centralized workflow.")
(define-public git
(package
(name "git")
- (version "2.29.2")
+ (version "2.30.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://kernel.org/software/scm/git/git-"
version ".tar.xz"))
(sha256
(base32
- "1h87yv117ypnc0yi86941089c14n91gixk8b6shj2y35prp47z7j"))))
+ "06ad6dylgla34k9am7d5z8y3rryc8ln3ibq5z0d74rcm20hm0wsm"))))
(build-system gnu-build-system)
(native-inputs
`(("native-perl" ,perl)
@@ -187,7 +188,7 @@ as well as the classic centralized workflow.")
version ".tar.xz"))
(sha256
(base32
- "14npkg9rnp2yclsx5p622qpm6byzfy5k5wb209vkmm5r60m4mm72"))))
+ "0xngjg60rwzrb9x32d1qbdd8szkzwcyha5qni7ilkldxsl2q8avv"))))
;; For subtree documentation.
("asciidoc" ,asciidoc-py3)
("docbook-xsl" ,docbook-xsl)