summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-12-15 15:40:38 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-20 16:21:41 +0100
commitc9930b1fdec5849f8f6bbdf8791dfbf6b524522b (patch)
tree2a2eccf6b8b08e9689c13621d30b84a77e68dfaf /gnu/packages/version-control.scm
parent442b2d9d7d09840cc23010e4d390308400780836 (diff)
downloadguix-patches-c9930b1fdec5849f8f6bbdf8791dfbf6b524522b.tar
guix-patches-c9930b1fdec5849f8f6bbdf8791dfbf6b524522b.tar.gz
gnu: Add rcshist.
* gnu/packages/version-control.scm (rcshist): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index d874011e9d..6fe7b00445 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -2070,6 +2070,28 @@ annotated RCS file describes the revision and date in which each line was
added to the file, and the author of each line.")
(license license:gpl2+)))
+(define-public rcshist
+ (package
+ (name "rcshist")
+ (version "1.04-20190106")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://invisible-mirror.net/archives/rcshist/rcshist-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "01ab3xwgm934lxr8bm758am3vxwx4hxx7cc9prbgqj5nh30vdg1n"))))
+ (build-system gnu-build-system)
+ (home-page "https://invisible-island.net/rcshist/rcshist.html")
+ (synopsis "Display RCS change history")
+ (description
+ "The @code{rcshist} utility displays the complete revision history of a
+set of RCS files including log messages and patches. It can also display the
+patch associated with a particular revision of an RCS file.")
+ (license (list license:bsd-2
+ license:bsd-3)))) ; bsd_queue.h
+
(define-public cvs
(package
(name "cvs")