summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-08 13:53:14 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-14 14:47:16 +0200
commitbdb6ff3ab13c94ae5b51171c4f1df87f8af398cc (patch)
tree8efcf1f74533a916a23bd7a32dd6c9091a65ab77 /gnu/packages/version-control.scm
parent909caad6bee076453bf67f707618ede88ded7a27 (diff)
downloadguix-patches-bdb6ff3ab13c94ae5b51171c4f1df87f8af398cc.tar
guix-patches-bdb6ff3ab13c94ae5b51171c4f1df87f8af398cc.tar.gz
gnu: mercurial: Update to 5.8.
* gnu/packages/version-control.scm (mercurial): Update to 5.8. [build-system]: Switch from ‘python-build-system’ to ‘gnu-build-system’, this will install additional things like man pages. [arguments]<#:make-flags>: Set PREFIX argument. [native-inputs]: Add ‘python-docutils’ for generating man pages. [inputs]: Add ‘python’. [description]: Fix formatting. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm24
1 files changed, 15 insertions, 9 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 5e89de8450..5438f6349c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1607,18 +1607,21 @@ execution of any hook written in any language before every commit.")
(define-public mercurial
(package
(name "mercurial")
- (version "5.6.1")
+ (version "5.8")
(source (origin
(method url-fetch)
(uri (string-append "https://www.mercurial-scm.org/"
"release/mercurial-" version ".tar.gz"))
(sha256
(base32
- "1bgz8f1a7lnmh6lzcvwg6q1yx6i7yibhwy06l4k55i04957jap75"))))
- (build-system python-build-system)
+ "17rhlmmkqz5ll3k68jfzpcifg3nndbcbc2nx7kw8xn3qcj7nlpgw"))))
+ (build-system gnu-build-system)
(arguments
- `(#:phases
+ `(#:make-flags
+ (list (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
(modify-phases %standard-phases
+ (delete 'configure)
(add-after 'unpack 'patch-tests
(lambda _
(substitute* '("tests/test-extdiff.t"
@@ -1671,17 +1674,20 @@ execution of any hook written in any language before every commit.")
;; The test suite takes a long time and produces little
;; output by default. Prevent timeouts due to silence.
"-v"))))))))
- ;; The following inputs are only needed to run the tests.
(native-inputs
- `(("python-nose" ,python-nose)
+ `(("python-docutils", python-docutils)
+ ;; The following inputs are only needed to run the tests.
+ ("python-nose" ,python-nose)
("unzip" ,unzip)
("which" ,which)))
+ (inputs
+ `(("python" ,python)))
(home-page "https://www.mercurial-scm.org/")
(synopsis "Decentralized version control system")
(description
- "Mercurial is a free, distributed source control management tool.
-It efficiently handles projects of any size
-and offers an easy and intuitive interface.")
+ "Mercurial is a free, distributed source control management tool. It
+efficiently handles projects of any size and offers an easy and intuitive
+interface.")
(license license:gpl2+)))
(define-public python-hg-evolve