summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorFoo Chuan Wei <chuanwei.foo@hotmail.com>2021-12-16 07:12:27 +0000
committerLudovic Courtès <ludo@gnu.org>2021-12-20 16:21:41 +0100
commitb2ec14a7dac8a22b9b73fb90a607720cf573ec02 (patch)
tree4ddaa8717adc9fb7a56f765e1e001196bd385ca7 /gnu/packages/version-control.scm
parent2a3027143c3ee8d6df4180e1be87e19d83e90af5 (diff)
downloadguix-patches-b2ec14a7dac8a22b9b73fb90a607720cf573ec02.tar
guix-patches-b2ec14a7dac8a22b9b73fb90a607720cf573ec02.tar.gz
gnu: Add tkrev.
* gnu/packages/version-control.scm (tkrev): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 6fe7b00445..7f5a89ea5b 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3254,6 +3254,52 @@ makes a directory under a specific root directory (by default @file{~/ghq})
using the remote repository URL's host and path.")
(license license:expat)))
+(define-public tkrev
+ (package
+ (name "tkrev")
+ (version "9.4.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://sourceforge/tkcvs/tkrev_" version ".tar.gz"))
+ (sha256
+ (base32 "0bpfbhkngzmwy476mfc69mkd94l0m2wxznrn0qzd81s450yxjw2q"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (delete 'build)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (bin (string-append out "/bin")))
+ (invoke "wish" "doinstall.tcl" "-nox" out)
+ (install-file "contrib/tkdirdiff" bin))))
+ (add-after 'install 'wrap-programs
+ (lambda* (#:key outputs #:allow-other-keys)
+ (for-each
+ (lambda (file)
+ (wrap-program (string-append (assoc-ref outputs "out")
+ "/bin/" file)
+ `("PATH" ":" prefix (,(dirname (which "wish"))))))
+ '("tkdiff"
+ "tkdirdiff"
+ "tkrev")))))
+ #:tests? #f))
+ (inputs
+ (list tk))
+ (home-page "https://tkcvs.sourceforge.io")
+ (synopsis "Graphical interface to CVS, Subversion, Git, and RCS")
+ (description
+ "TkRev (formerly TkCVS) is a Tcl/Tk-based graphical interface to the CVS,
+Subversion and Git configuration management systems. It will also help with
+RCS. It shows the status of the files in the current working directory, and
+has tools for tagging, merging, checking in/out, and other user operations.
+TkDiff is included for browsing and merging your changes.")
+ (license license:gpl2+)))
+
(define-public git-filter-repo
(package
(name "git-filter-repo")