summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-23 11:22:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-23 11:29:38 +0100
commitb15e543d303ea58fdc0f0541c708389f9d513e3d (patch)
tree5c4bd48d67d4d3cd4806269dcabf58382f448bed /gnu/packages/version-control.scm
parent4efc08d895274ee39e6e6e5c49121fb05a0281b6 (diff)
parentdaf7b5ecef8de0e536ffd8d2957f022d010767a8 (diff)
downloadguix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar
guix-patches-b15e543d303ea58fdc0f0541c708389f9d513e3d.tar.gz
Merge branch 'master' into core-updates-frozen
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 9d1c84b563..d80f7c55a6 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -42,6 +42,7 @@
;;; Copyright © 2021 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
;;; Copyright © 2021 jgart <jgart@dismail.de>
+;;; Copyright © 2021 Foo Chuan Wei <chuanwei.foo@hotmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2055,6 +2056,14 @@ projects, from individuals to large-scale enterprise operations.")
"1if5pa4iip2p70gljm54nggfdnsfjxa4cqz8fpj07lvsijary39s"))
(patches (search-patches "rcs-5.10.0-no-stdin.patch"))))
(build-system gnu-build-system)
+ (arguments `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'install 'install-rcsfreeze
+ (lambda* (#:key outputs #:allow-other-keys)
+ (chmod "src/rcsfreeze" #o755)
+ (install-file
+ "src/rcsfreeze"
+ (string-append (assoc-ref outputs "out") "/bin")))))))
(native-inputs `(("ed" ,ed)))
(home-page "https://www.gnu.org/software/rcs/")
(synopsis "Per-file local revision control system")
@@ -2066,6 +2075,27 @@ administration files, for example, which are often inherently local to one
machine.")
(license license:gpl3+)))
+(define-public rcs-blame
+ (package
+ (name "rcs-blame")
+ (version "1.3.1-20210207")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://invisible-mirror.net/archives/rcs-blame/blame-"
+ version ".tgz"))
+ (sha256
+ (base32
+ "1j0brsvdx3hlbwchddafh8r2xmxv5vg4ahpd68v4bb9xhcq6pcih"))))
+ (build-system gnu-build-system)
+ (home-page "https://invisible-island.net/rcs-blame/rcs-blame.html")
+ (synopsis "Display the last modification for each line in an RCS file")
+ (description
+ "@code{blame} outputs an annotated revision from each RCS file. An
+annotated RCS file describes the revision and date in which each line was
+added to the file, and the author of each line.")
+ (license license:gpl2+)))
+
(define-public cvs
(package
(name "cvs")