summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorXinglu Chen <public@yoctocell.xyz>2021-05-15 11:17:12 +0200
committerLudovic Courtès <ludo@gnu.org>2021-05-16 23:28:11 +0200
commitae0882bbd686cb213420bd7b84601e0c97771cf7 (patch)
treebdf04c09bfd6f3e6873cc34b74cbf5d93b1575d9 /gnu/packages/version-control.scm
parent541f93ada0a1e32c615f70b55ec41cdfba44668f (diff)
downloadguix-patches-ae0882bbd686cb213420bd7b84601e0c97771cf7.tar
guix-patches-ae0882bbd686cb213420bd7b84601e0c97771cf7.tar.gz
gnu: mercurial: Patch to make it read HGEXTENSIONPATH.
This will make Mercurial be able to find third-party extensions installed with Guix, without having to set PYTHONPATH. * gnu/packages/patches/mercurial-hg-extension-path.patch: New file. * gnu/local.mk (dist_patch_DATA): Register the patch. * gnu/packages/version-control.scm (mercurial)[origin](patches): Apply the patch. [native-search-paths]: Add HGEXTENSIONPATH. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 3a6de3399e..167495c80c 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1614,6 +1614,7 @@ execution of any hook written in any language before every commit.")
(method url-fetch)
(uri (string-append "https://www.mercurial-scm.org/"
"release/mercurial-" version ".tar.gz"))
+ (patches (search-patches "mercurial-hg-extension-path.patch"))
(sha256
(base32
"17rhlmmkqz5ll3k68jfzpcifg3nndbcbc2nx7kw8xn3qcj7nlpgw"))))
@@ -1684,6 +1685,11 @@ execution of any hook written in any language before every commit.")
("which" ,which)))
(inputs
`(("python" ,python)))
+ ;; Find third-party extensions.
+ (native-search-paths
+ (list (search-path-specification
+ (variable "HGEXTENSIONPATH")
+ (files '("lib/python3.8/site-packages/hgext3rd")))))
(home-page "https://www.mercurial-scm.org/")
(synopsis "Decentralized version control system")
(description