summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorJosh Marshall <joshua.r.marshall.1991@gmail.com>2020-05-26 23:12:26 -0400
committerTobias Geerinckx-Rice <me@tobias.gr>2020-05-27 13:12:32 +0200
commit8c1d7c8511ceca1fe650f3dd94b63a4945a1f9b7 (patch)
treebe1c97bf3632b516b30674025318f89db5aeb2a0 /gnu/packages/version-control.scm
parent3c0d165ad3627aa8c7696e4ec064da0bb947f23f (diff)
downloadguix-patches-8c1d7c8511ceca1fe650f3dd94b63a4945a1f9b7.tar
guix-patches-8c1d7c8511ceca1fe650f3dd94b63a4945a1f9b7.tar.gz
gnu: aegis: Fix build failure.
* gnu/packages/version-control.scm (aegis)[arguments]: Add ‘CXXFLAGS=-std=c++03’ to #:configure-flags. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr>
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 4f3968286d..27c1f3beb9 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1885,7 +1885,10 @@ accessed and migrated on modern systems.")
("ed" ,ed)))
(arguments
`(#:configure-flags (list "--with-no-aegis-configured"
- "--sharedstatedir=/var/com/aegis")
+ "--sharedstatedir=/var/com/aegis"
+ ;; Uses the old 'throw()' specifier with 'new'
+ ;; which changed in C++11.
+ "CXXFLAGS=-std=c++03")
#:parallel-build? #f ; There are some nasty racy rules in the Makefile.
#:phases
(modify-phases %standard-phases