summaryrefslogtreecommitdiff
path: root/gnu/packages/version-control.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-04-04 14:27:28 +0200
committerLudovic Courtès <ludo@gnu.org>2019-04-04 17:47:01 +0200
commit804744b338455b0ab8775351f757427047314139 (patch)
tree1275e7e226788c65185ede827a472330e46b9676 /gnu/packages/version-control.scm
parenta7ad4505b7a09f32e2727a333e11716739efb713 (diff)
downloadguix-patches-804744b338455b0ab8775351f757427047314139.tar
guix-patches-804744b338455b0ab8775351f757427047314139.tar.gz
gnu: Add (gnu packages haskell-apps).
* gnu/packages/version-control.scm (darcs, git-annex): Move to... * gnu/packages/haskell-apps.scm: ... here. New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/version-control.scm')
-rw-r--r--gnu/packages/version-control.scm231
1 files changed, 0 insertions, 231 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index db096d8587..56d631fb2d 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -48,7 +48,6 @@
#:use-module (guix build-system ant)
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu)
- #:use-module (guix build-system haskell)
#:use-module (guix build-system python)
#:use-module (guix build-system trivial)
#:use-module (gnu packages apr)
@@ -69,10 +68,6 @@
#:use-module (gnu packages gl)
#:use-module (gnu packages groff)
#:use-module (gnu packages guile)
- #:use-module (gnu packages haskell)
- #:use-module (gnu packages haskell-check)
- #:use-module (gnu packages haskell-crypto)
- #:use-module (gnu packages haskell-web)
#:use-module (gnu packages image)
#:use-module (gnu packages java)
#:use-module (gnu packages linux)
@@ -1959,105 +1954,6 @@ a built-in wiki, built-in file browsing, built-in tickets system, etc.")
be served with a HTTP file server of your choice.")
(license license:expat)))
-;; Darcs has no https support: http://irclog.perlgeek.de/darcs/2016-09-17
-;; http://darcs.net/manual/Configuring_darcs.html#SECTION00440070000000000000
-;; and results of search engines will show that if the protocol is http, https
-;; is never mentioned.
-(define-public darcs
- (package
- (name "darcs")
- (version "2.14.2")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/darcs/"
- "darcs-" version ".tar.gz"))
- (sha256
- (base32
- "0zm2486gyhiga1amclbg92cd09bvki6vgh0ll75hv5kl72j61lb5"))
- (modules '((guix build utils)))
- ;; Remove time-dependent code for reproducibility.
- (snippet
- '(begin
- (substitute* "darcs/darcs.hs"
- (("__DATE__") "\"1970-01-01\"")
- (("__TIME__") "\"00:00:00\""))
- #t))))
- (build-system haskell-build-system)
- (arguments
- `(#:configure-flags '("-fpkgconfig" "-fcurl" "-flibiconv" "-fthreaded"
- "-fnetwork-uri" "-fhttp" "--flag=executable"
- "--flag=library")
- #:phases
- (modify-phases %standard-phases
- (add-after 'patch-source-shebangs 'patch-sh
- (lambda _
- (substitute* "tests/issue538.sh"
- (("/bin/sh") (which "sh")))
- #t)))))
- (inputs
- `(("ghc-cmdargs" ,ghc-cmdargs)
- ("ghc-split" ,ghc-split)
- ("ghc-test-framework-quickcheck2" ,ghc-test-framework-quickcheck2)
- ("ghc-test-framework-hunit" ,ghc-test-framework-hunit)
- ("ghc-test-framework" ,ghc-test-framework)
- ("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-findbin" ,ghc-findbin)
- ("ghc-hunit" ,ghc-hunit)
- ("ghc-async" ,ghc-async)
- ("ghc-attoparsec" ,ghc-attoparsec)
- ("ghc-base16-bytestring" ,ghc-base16-bytestring)
- ("ghc-bytestring-builder" ,ghc-bytestring-builder)
- ("ghc-cryptohash" ,ghc-cryptohash)
- ("ghc-data-ordlist" ,ghc-data-ordlist)
- ("ghc-fgl" ,ghc-fgl)
- ("ghc-system-filepath" ,ghc-system-filepath)
- ("ghc-graphviz" ,ghc-graphviz)
- ("ghc-hashable" ,ghc-hashable)
- ("ghc-html" ,ghc-html)
- ("ghc-mmap" ,ghc-mmap)
- ("ghc-old-time" ,ghc-old-time)
- ("ghc-parsec" ,ghc-parsec)
- ("ghc-random" ,ghc-random)
- ("ghc-regex-applicative" ,ghc-regex-applicative)
- ("ghc-regex-compat-tdfa" ,ghc-regex-compat-tdfa)
- ("ghc-sandi" ,ghc-sandi)
- ("ghc-shelly" ,ghc-shelly)
- ("ghc-tar" ,ghc-tar)
- ("ghc-transformers-compat" ,ghc-transformers-compat)
- ("ghc-unix-compat" ,ghc-unix-compat)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-vector" ,ghc-vector)
- ("ghc-zip-archive" ,ghc-zip-archive)
- ("ghc-zlib" ,ghc-zlib)
- ("ghc-http" ,ghc-http)
- ("curl" ,curl)
- ("ghc" ,ghc)
- ("ncurses" ,ncurses)
- ("perl" ,perl)
- ("libiconv" ,libiconv)
- ("ghc-network" ,ghc-network)
- ("ghc-network-uri" ,ghc-network-uri)))
- (native-inputs
- `(("pkg-config" ,pkg-config)))
- (home-page "http://darcs.net")
- (synopsis "Distributed Revision Control System")
- (description
- "Darcs is a revision control system. It is:
-
-@enumerate
-@item Distributed: Every user has access to the full command set, removing boundaries
-between server and client or committer and non-committers.
-@item Interactive: Darcs is easy to learn and efficient to use because it asks you
-questions in response to simple commands, giving you choices in your work flow.
-You can choose to record one change in a file, while ignoring another. As you update
-from upstream, you can review each patch name, even the full diff for interesting
-patches.
-@item Smart: Originally developed by physicist David Roundy, darcs is based on a
-unique algebra of patches called @url{http://darcs.net/Theory,Patchtheory}.
-@end enumerate")
- (license license:gpl2)))
-
(define-public java-jgit
(package
(name "java-jgit")
@@ -2221,133 +2117,6 @@ cases like all those little scripts in your @file{~/bin} directory, or a
directory full of HOWTOs.")
(license license:bsd-2)))
-(define-public git-annex
- (package
- (name "git-annex")
- (version "6.20180926")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "https://hackage.haskell.org/package/"
- "git-annex/git-annex-" version ".tar.gz"))
- (sha256
- (base32
- "1251rj8h63y30sfqk0zh670yhz14p256y59n3590pg015pf3575d"))))
- (build-system haskell-build-system)
- (arguments
- `(#:configure-flags
- '("--flags=-Android -Assistant -Pairing -S3 -Webapp -WebDAV")
- #:phases
- (modify-phases %standard-phases
- (add-before 'configure 'patch-shell
- (lambda _
- (substitute* "Utility/Shell.hs"
- (("/bin/sh") (which "sh")))
- #t))
- (add-before 'configure 'factor-setup
- (lambda _
- ;; Factor out necessary build logic from the provided
- ;; `Setup.hs' script. The script as-is does not work because
- ;; it cannot find its dependencies, and there is no obvious way
- ;; to tell it where to look. Note that we do not preserve the
- ;; code that installs man pages here.
- (call-with-output-file "PreConf.hs"
- (lambda (out)
- (format out "import qualified Build.Configure as Configure~%")
- (format out "main = Configure.run Configure.tests~%")))
- (call-with-output-file "Setup.hs"
- (lambda (out)
- (format out "import Distribution.Simple~%")
- (format out "main = defaultMain~%")))
- #t))
- (add-before 'configure 'pre-configure
- (lambda _
- (invoke "runhaskell" "PreConf.hs")
- #t))
- (replace 'check
- (lambda _
- ;; We need to set the path so that Git recognizes
- ;; `git annex' as a custom command.
- (setenv "PATH" (string-append (getenv "PATH") ":"
- (getcwd) "/dist/build/git-annex"))
- (with-directory-excursion "dist/build/git-annex"
- (symlink "git-annex" "git-annex-shell"))
- (invoke "git-annex" "test")
- #t))
- (add-after 'install 'install-symlinks
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (bin (string-append out "/bin")))
- (symlink (string-append bin "/git-annex")
- (string-append bin "/git-annex-shell"))
- (symlink (string-append bin "/git-annex")
- (string-append bin "/git-remote-tor-annex"))
- #t))))))
- (inputs
- `(("curl" ,curl)
- ("ghc-aeson" ,ghc-aeson)
- ("ghc-async" ,ghc-async)
- ("ghc-bloomfilter" ,ghc-bloomfilter)
- ("ghc-byteable" ,ghc-byteable)
- ("ghc-case-insensitive" ,ghc-case-insensitive)
- ("ghc-crypto-api" ,ghc-crypto-api)
- ("ghc-cryptonite" ,ghc-cryptonite)
- ("ghc-data-default" ,ghc-data-default)
- ("ghc-disk-free-space" ,ghc-disk-free-space)
- ("ghc-dlist" ,ghc-dlist)
- ("ghc-edit-distance" ,ghc-edit-distance)
- ("ghc-esqueleto" ,ghc-esqueleto)
- ("ghc-exceptions" ,ghc-exceptions)
- ("ghc-feed" ,ghc-feed)
- ("ghc-free" ,ghc-free)
- ("ghc-hslogger" ,ghc-hslogger)
- ("ghc-http-client" ,ghc-http-client)
- ("ghc-http-conduit" ,ghc-http-conduit)
- ("ghc-http-types" ,ghc-http-types)
- ("ghc-ifelse" ,ghc-ifelse)
- ("ghc-memory" ,ghc-memory)
- ("ghc-monad-control" ,ghc-monad-control)
- ("ghc-monad-logger" ,ghc-monad-logger)
- ("ghc-network" ,ghc-network)
- ("ghc-old-locale" ,ghc-old-locale)
- ("ghc-optparse-applicative" ,ghc-optparse-applicative)
- ("ghc-persistent" ,ghc-persistent)
- ("ghc-persistent-sqlite" ,ghc-persistent-sqlite)
- ("ghc-persistent-template" ,ghc-persistent-template)
- ("ghc-quickcheck" ,ghc-quickcheck)
- ("ghc-random" ,ghc-random)
- ("ghc-regex-tdfa" ,ghc-regex-tdfa)
- ("ghc-resourcet" ,ghc-resourcet)
- ("ghc-safesemaphore" ,ghc-safesemaphore)
- ("ghc-sandi" ,ghc-sandi)
- ("ghc-securemem" ,ghc-securemem)
- ("ghc-socks" ,ghc-socks)
- ("ghc-split" ,ghc-split)
- ("ghc-stm" ,ghc-stm)
- ("ghc-stm-chans" ,ghc-stm-chans)
- ("ghc-tagsoup" ,ghc-tagsoup)
- ("ghc-text" ,ghc-text)
- ("ghc-unix-compat" ,ghc-unix-compat)
- ("ghc-unordered-containers" ,ghc-unordered-containers)
- ("ghc-utf8-string" ,ghc-utf8-string)
- ("ghc-uuid" ,ghc-uuid)
- ("git" ,git)
- ("rsync" ,rsync)))
- (native-inputs
- `(("ghc-tasty" ,ghc-tasty)
- ("ghc-tasty-hunit" ,ghc-tasty-hunit)
- ("ghc-tasty-quickcheck" ,ghc-tasty-quickcheck)
- ("ghc-tasty-rerun" ,ghc-tasty-rerun)))
- (home-page "https://git-annex.branchable.com/")
- (synopsis "Manage files with Git, without checking in their contents")
- (description "This package allows managing files with Git, without
-checking the file contents into Git. It can store files in many places,
-such as local hard drives and cloud storage services. It can also be
-used to keep a folder in sync between computers.")
- ;; The web app is released under the AGPLv3+.
- (license (list license:gpl3+
- license:agpl3+))))
-
(define-public git-when-merged
;; Use an unreleased version to get a PY3 compatibility fix.
(let ((commit "ab6af7865a0ba55ba364a6c507e0be6f84f31c6d"))