summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-10-17 23:08:45 +0200
committerLudovic Courtès <ludo@gnu.org>2014-10-17 23:23:20 +0200
commit67a86d3b8d17b921728eec7776677582cfdd9266 (patch)
treed8a8ecc9ad942f14e159ce7149ae99dd26e22d63 /gnu/packages/valgrind.scm
parent1d830bc0c2fd3c149d711d8d265a04a5f4751388 (diff)
downloadguix-patches-67a86d3b8d17b921728eec7776677582cfdd9266.tar
guix-patches-67a86d3b8d17b921728eec7776677582cfdd9266.tar.gz
gnu: valgrind: Don't build on mipsel64-linux.
* gnu/packages/valgrind.scm (valgrind): Add 'supported-systems'.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 82e3b80f7f..44a8381235 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -60,4 +60,8 @@
tools. There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
- (license gpl2+)))
+ (license gpl2+)
+
+ ;; Building VEX on mips64el-linux fails with "opcode not supported on this
+ ;; processor: mips3".
+ (supported-systems (delete "mips64el-linux" %supported-systems))))