summaryrefslogtreecommitdiff
path: root/gnu/packages/valgrind.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-03-06 16:00:12 +0100
committerMarius Bakke <mbakke@fastmail.com>2019-03-06 16:32:31 +0100
commit350b7f8a7441d7df89249b356299a843b9a18794 (patch)
treee565d0d55f7ac6ee01208a4bfda0edd64c44cf14 /gnu/packages/valgrind.scm
parentf339df425eb00cb8d9418b3a338d7e03afd4a09c (diff)
downloadguix-patches-350b7f8a7441d7df89249b356299a843b9a18794.tar
guix-patches-350b7f8a7441d7df89249b356299a843b9a18794.tar.gz
gnu: valgrind: Update to 3.14.0.
* gnu/packages/patches/valgrind-glibc-compat.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/valgrind.scm (valgrind): Update to 3.14.0. [supported-systems]: Add mips64el-linux.
Diffstat (limited to 'gnu/packages/valgrind.scm')
-rw-r--r--gnu/packages/valgrind.scm13
1 files changed, 4 insertions, 9 deletions
diff --git a/gnu/packages/valgrind.scm b/gnu/packages/valgrind.scm
index 0a6206b3b1..9952fa1647 100644
--- a/gnu/packages/valgrind.scm
+++ b/gnu/packages/valgrind.scm
@@ -32,7 +32,7 @@
(define-public valgrind
(package
(name "valgrind")
- (version "3.13.0")
+ (version "3.14.0")
(source (origin
(method url-fetch)
(uri (list (string-append "http://www.valgrind.org/downloads"
@@ -41,9 +41,8 @@
"/valgrind-" version ".tar.bz2")))
(sha256
(base32
- "0fqc3684grrbxwsic1rc5ryxzxmigzjx9p5vf3lxa37h0gpq0rnp"))
- (patches (search-patches "valgrind-enable-arm.patch"
- "valgrind-glibc-compat.patch"))))
+ "19ds42jwd89zrsjb94g7gizkkzipn8xik3xykrpcqxylxyzi2z03"))
+ (patches (search-patches "valgrind-enable-arm.patch"))))
(build-system gnu-build-system)
(outputs '("doc" ;16 MB
"out"))
@@ -79,8 +78,4 @@
tools. There are Valgrind tools that can automatically detect many memory
management and threading bugs, and profile your programs in detail. You can
also use Valgrind to build new tools.")
- (license gpl2+)
-
- ;; Building VEX on mips64el-linux fails with "opcode not supported on this
- ;; processor: mips3".
- (supported-systems (delete "mips64el-linux" %supported-systems))))
+ (license gpl2+)))