summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-02 17:31:28 +0200
commit50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64 (patch)
tree64f16d207bad28a9dfda9cce95e6337483a40066 /gnu/packages/upnp.scm
parenta8cb1e72ef351330d1521833c1b270dcc0da593f (diff)
parentafc57916e5398737e13d94b3823983783221eb63 (diff)
downloadguix-patches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar
guix-patches-50e6c1bf2ef2f006baa8cac80dfbb12ca2ba6d64.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index c7ad33c17b..25b73189bc 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -4,6 +4,7 @@
;;; Copyright © 2016, 2017, 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Theodoros Foradis <theodoros@foradis.org>
;;; Copyright © 2019 Jens Mølgaard <jens@zete.tk>
+;;; Copyright © 2020 Jan Wielkiewicz <tona_kosmicznego_smiecia@interia.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -28,6 +29,7 @@
#:use-module (gnu packages photo)
#:use-module (gnu packages image)
#:use-module (gnu packages mp3)
+ #:use-module (gnu packages pkg-config)
#:use-module (gnu packages xiph)
#:use-module (gnu packages sqlite)
#:use-module (gnu packages python)
@@ -92,15 +94,21 @@ over IRC, instant messaging, network games, and most server software.")
(define-public libupnp
(package
(name "libupnp")
- (version "1.6.25")
+ (version "1.8.6")
(source
(origin
- (method url-fetch)
- (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
- version "/" name "-" version ".tar.bz2"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/pupnp/pupnp.git")
+ (commit (string-append "release-" version))))
(sha256
(base32
- "0hzsd7rvfa87b4hxg9yj4xhdfxx9sp09r9sqdl3mqhvmcyw018y5"))))
+ "1jlb6qh47513h2simy0zxia5q61w1c31mnwmjqpr2nf832lmnpk4"))))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
(build-system gnu-build-system)
(arguments
;; The tests require a network device capable of multicasting which is