summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-01-06 09:34:29 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-01-06 09:34:29 +0200
commit406008a2ac8b03317623a9967ec2e5fd3dca7650 (patch)
treef3271049ac599531d61db7ed80752fe2a7bdd36f /gnu/packages/upnp.scm
parentde194a39d3d49c7424d08e04b675ff649035e7b1 (diff)
downloadguix-patches-406008a2ac8b03317623a9967ec2e5fd3dca7650.tar
guix-patches-406008a2ac8b03317623a9967ec2e5fd3dca7650.tar.gz
gnu: readymedia: Update to 1.3.0.
Fixes CVE-2020-28926. * gnu/packages/upnp.scm (readymedia): Update to 1.3.0. [arguments]: Add configure-flag to not record kernel version of build machine. Add phase to remove spurious substitution of ffmpeg libraries. [inputs]: Add zlib.
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm17
1 files changed, 14 insertions, 3 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index fed5eb18ed..9106dd1beb 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -26,6 +26,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages gettext)
#:use-module (gnu packages autotools)
+ #:use-module (gnu packages compression)
#:use-module (gnu packages video)
#:use-module (gnu packages photo)
#:use-module (gnu packages image)
@@ -126,7 +127,7 @@ and others.")
(define-public readymedia
(package
(name "readymedia")
- (version "1.2.1")
+ (version "1.3.0")
(source
(origin
(method git-fetch)
@@ -137,8 +138,17 @@ and others.")
(file-name (git-file-name name version))
(sha256
(base32
- "160915yv38k0p5zmyncs12kkbbcd8m8fk9jq70fkfd5x6dz40xm4"))))
+ "0g04lffj37wdv5bnpl5faxpnmlj6bbk8y7ziaz2wp6h82g6kb5wj"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags '("--with-os-name=Linux") ; uname -s
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-source
+ (lambda _
+ (substitute* "Makefile.am"
+ ((".*LIBAVUTIL_LIBS.*") ""))
+ #t)))))
(native-inputs
`(("automake" ,automake)
("autoconf" ,autoconf)
@@ -150,7 +160,8 @@ and others.")
("flac" ,flac)
("libvorbis" ,libvorbis)
("sqlite" ,sqlite)
- ("ffmpeg" ,ffmpeg)))
+ ("ffmpeg" ,ffmpeg)
+ ("zlib" ,zlib)))
(home-page "https://sourceforge.net/projects/minidlna/")
(synopsis "DLNA/UPnP-AV media server")
(description "ReadyMedia (formerly known as MiniDLNA) is a simple media