summaryrefslogtreecommitdiff
path: root/gnu/packages/upnp.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-12-25 22:48:57 -0500
committerLeo Famulari <leo@famulari.name>2017-12-25 22:52:03 -0500
commit0b5eff847f8412aa53938a1c165c90848d0c87ca (patch)
tree423a14b30d187c0a91d039a9ce31facd721c0363 /gnu/packages/upnp.scm
parentc9c7c030be6b22829b995c0530c00043ac93eca1 (diff)
downloadguix-patches-0b5eff847f8412aa53938a1c165c90848d0c87ca.tar
guix-patches-0b5eff847f8412aa53938a1c165c90848d0c87ca.tar.gz
gnu: Move libupnp to (gnu packages upnp).
* gnu/packages/libupnp.scm: Delete file. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove it. * gnu/packages/upnp.scm (libupnp): New variable.
Diffstat (limited to 'gnu/packages/upnp.scm')
-rw-r--r--gnu/packages/upnp.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/upnp.scm b/gnu/packages/upnp.scm
index f2669f11a8..41f9411281 100644
--- a/gnu/packages/upnp.scm
+++ b/gnu/packages/upnp.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
+;;; Copyright © 2015 Federico Beffa <beffa@fbengineering.ch>
;;; Copyright © 2016, 2017 Tobias Geerinckx-Rice <me@tobias.gr>
;;;
;;; This file is part of GNU Guix.
@@ -74,3 +75,32 @@ include peer-to-peer applications, active-mode FTP clients, DCC file transfers
over IRC, instant messaging, network games, and most server software.")
(license
(x11-style "file://LICENSE" "See 'LICENSE' file in the distribution"))))
+
+(define-public libupnp
+ (package
+ (name "libupnp")
+ (version "1.6.24")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/pupnp/pupnp/libUPnP%20"
+ version "/" name "-" version ".tar.bz2"))
+ (sha256
+ (base32
+ "15ngi1i7cvsv7g15fb9bkswvi99d1plz52x5qgjn4h5vyfddg0vx"))))
+ (build-system gnu-build-system)
+ (arguments
+ ;; The tests require a network device capable of multicasting which is
+ ;; not available in the build environment. See
+ ;; https://lists.gnu.org/archive/html/guix-devel/2015-01/msg00312.html.
+ `(#:tests? #f
+ #:configure-flags '("--enable-ipv6")))
+ (home-page "http://pupnp.sourceforge.net")
+ (synopsis "Portable SDK for UPnP Devices")
+ (description
+ "The portable SDK for UPnP Devices (libupnp) provides developers with an
+API and code for building control points, devices, and bridges that are
+compliant with Version 1.0 of the Universal Plug and Play Device Architecture
+Specification and support several operating systems like Linux, *BSD, Solaris
+and others.")
+ (license bsd-3)))