summaryrefslogtreecommitdiff
path: root/gnu/packages/uglifyjs.scm
diff options
context:
space:
mode:
authorCharles <charles.b.jackson@protonmail.com>2021-07-12 22:27:35 -0500
committerEfraim Flashner <efraim@flashner.co.il>2021-07-19 14:43:29 +0300
commitd16148fcfdf196117f27933a30e3398aa9290624 (patch)
tree906bac4868048f65549806706db3e7044da43c9b /gnu/packages/uglifyjs.scm
parentbfa847dbe04176a9222f47381a4fa5d5252f9aa8 (diff)
downloadguix-patches-d16148fcfdf196117f27933a30e3398aa9290624.tar
guix-patches-d16148fcfdf196117f27933a30e3398aa9290624.tar.gz
gnu: Add node-uglify-js.
* gnu/packages/uglifyjs.scm (node-uglify-js, uglifyjs): New variables. * gnu/local.mk (GNU_SYSTEM_MODULES): Register it. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/uglifyjs.scm')
-rw-r--r--gnu/packages/uglifyjs.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/uglifyjs.scm b/gnu/packages/uglifyjs.scm
new file mode 100644
index 0000000000..275553bb60
--- /dev/null
+++ b/gnu/packages/uglifyjs.scm
@@ -0,0 +1,50 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2021 Charles <charles.b.jackson@protonmail.com>
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages uglifyjs)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix packages)
+ #:use-module (guix git-download)
+ #:use-module (guix build-system node)
+ #:use-module (gnu packages node-xyz))
+
+(define-public node-uglify-js
+ (package
+ (name "node-uglify-js")
+ (version "3.13.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mishoo/UglifyJS")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0q1f91xwwm829cl5v727d4qkxy4yh7wri3pgl89f0m3a4y1n7hi4"))))
+ (build-system node-build-system)
+ (native-inputs
+ `(("node-acorn" ,node-acorn)
+ ("node-semver" ,node-semver)))
+ (home-page "https://lisperator.net/uglifyjs/")
+ (synopsis "JavaScript parser / mangler / compressor / beautifier toolkit")
+ (description "UglifyJS is a JavaScript compressor/minifier written in
+JavaScript. It also contains tools that allow one to automate working with
+JavaScript code: parser, code generator, compressor, mangler, scope analyzer,
+tree walker, and tree transformer.")
+ (license license:bsd-2)))
+
+(define-public uglifyjs node-uglify-js)