summaryrefslogtreecommitdiff
path: root/gnu/packages/tv.scm
diff options
context:
space:
mode:
authorAlex Kost <alezost@gmail.com>2016-05-02 13:42:33 +0300
committerAlex Kost <alezost@gmail.com>2016-05-04 23:08:39 +0300
commitaf5640d1dd18328dbfec5cb11f73224efd47f1aa (patch)
tree53c3a48955fd690feae84808ef9be78e5f2aa04c /gnu/packages/tv.scm
parent41447b3199a1455c26639d535c6397d991611274 (diff)
downloadguix-patches-af5640d1dd18328dbfec5cb11f73224efd47f1aa.tar
guix-patches-af5640d1dd18328dbfec5cb11f73224efd47f1aa.tar.gz
gnu: tvtime: Update to 1.0.10.
* gnu/packages/tv.scm (tvtime): Update to 1.0.10. [source]: Remove patches. [inputs]: Add 'alsa-lib'. * gnu/packages/patches/tvtime-gcc41.patch, gnu/packages/patches/tvtime-pngoutput.patch, gnu/packages/patches/tvtime-videodev2.patch, gnu/packages/patches/tvtime-xmltv.patch: Remove files. * gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/tv.scm')
-rw-r--r--gnu/packages/tv.scm25
1 files changed, 12 insertions, 13 deletions
diff --git a/gnu/packages/tv.scm b/gnu/packages/tv.scm
index f58c03623e..2db71b8491 100644
--- a/gnu/packages/tv.scm
+++ b/gnu/packages/tv.scm
@@ -1,5 +1,5 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2015 Alex Kost <alezost@gmail.com>
+;;; Copyright © 2015, 2016 Alex Kost <alezost@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,30 +22,29 @@
#:use-module (guix build-system gnu)
#:use-module ((guix licenses) #:prefix license:)
#:use-module (gnu packages)
- #:use-module (gnu packages xorg)
- #:use-module (gnu packages image)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages fontutils)
+ #:use-module (gnu packages image)
+ #:use-module (gnu packages linux)
#:use-module (gnu packages xml)
- #:use-module (gnu packages fontutils))
+ #:use-module (gnu packages xorg))
(define-public tvtime
(package
(name "tvtime")
- (version "1.0.2")
+ (version "1.0.10")
(source (origin
(method url-fetch)
- (uri (string-append "mirror://sourceforge/tvtime/tvtime-"
- version ".tar.gz"))
+ (uri (string-append
+ "http://linuxtv.org/downloads/tvtime/tvtime-"
+ version ".tar.gz"))
(sha256
(base32
- "08q5gzbyz0lxb730rz6d6amkzimlc7nanv6n50j2bpw4n2xa9wmf"))
- (patches (search-patches "tvtime-videodev2.patch"
- "tvtime-pngoutput.patch"
- "tvtime-xmltv.patch"
- "tvtime-gcc41.patch"))))
+ "1mk6dni82n8jv5wsrrpqzcwrg9ccx9vijb5sbm7gqm2y0h40q5y9"))))
(build-system gnu-build-system)
(inputs
- `(("libx11" ,libx11)
+ `(("alsa-lib" ,alsa-lib)
+ ("libx11" ,libx11)
("libxext" ,libxext)
("libxt" ,libxt)
("libxtst" ,libxtst)