summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:49 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commitec5ea1917a2706dfce006f6c3b87eb4f4b5dbf37 (patch)
treecccfb88714a4edd99f5e2bafb5d0cd26298498db /gnu/packages/tryton.scm
parent354afe47341e20b3faf5ebdddb51ee83cc1da1d6 (diff)
downloadguix-patches-ec5ea1917a2706dfce006f6c3b87eb4f4b5dbf37.tar
guix-patches-ec5ea1917a2706dfce006f6c3b87eb4f4b5dbf37.tar.gz
gnu: Add trytond-stock-inventory-location.
* gnu/packages/tryton.scm (trytond-stock-inventory-location): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 045e7ceeb9..2681556669 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3787,6 +3787,31 @@ to create stock moves toward customers with a date in the future. This allows
other stock mecanisms to anticipate customer demand.")
(license license:gpl3+)))
+(define-public trytond-stock-inventory-location
+ (package
+ (name "trytond-stock-inventory-location")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_inventory_location" version))
+ (sha256
+ (base32 "0mvgday5qhmx89xikklr2ad2xa7zxkiysxa2bqsf76imvx4801q6"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_inventory_location"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-stock-inventory-location")
+ (synopsis "Tryton module to create inventories by locations")
+ (description "The @emph{Stock Inventory Location} Tryton module adds a new
+wizard \"Create Inventories\" under the \"Inventories\" sub-menu.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-lot
(package
(name "trytond-stock-lot")