summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:26 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commitd6b60b86b59632b38684af883ab91733e11dbe6d (patch)
tree9dae965c3f0635d25c05436f7f3ef19202c6ed96 /gnu/packages/tryton.scm
parent09ec25e3facae44a3605fb9b7124ddd920afb7c1 (diff)
downloadguix-patches-d6b60b86b59632b38684af883ab91733e11dbe6d.tar
guix-patches-d6b60b86b59632b38684af883ab91733e11dbe6d.tar.gz
gnu: Add trytond-product-cost-warehouse.
* gnu/packages/tryton.scm (trytond-product-cost-warehouse): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 28adde6eeb..3ae0f3777a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2244,6 +2244,35 @@ historic cost price is needed, the value is taken from this history for goods
and assets.")
(license license:gpl3+)))
+(define-public trytond-product-cost-warehouse
+ (package
+ (name "trytond-product-cost-warehouse")
+ (version "6.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_product_cost_warehouse" version))
+ (sha256
+ (base32 "12fcnmcx4m5wyw1hi3k175iiis5m18fcs72b04y14km583s6jcfr"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "product_cost_warehouse"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-account-stock-continental" ,trytond-account-stock-continental)
+ ("trytond-product-cost-fifo" ,trytond-product-cost-fifo)
+ ("trytond-product-cost-history" ,trytond-product-cost-history)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-product" ,trytond-product)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-product-cost-warehouse")
+ (synopsis "Tryton module to compute product cost per warehouse")
+ (description "The @emph{Product Cost Warehouse} Trython module allows the
+cost price of products to be calculated separately for each warehouse.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")