summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:45 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commitc7797fd49ea5c6c69bcc8547922b112d4cf488cc (patch)
treed95b1a78525d3965471c52151db6b1fd9fa8fe16 /gnu/packages/tryton.scm
parentc030a075c81428248829f6ecde3bbf59ff711a3a (diff)
downloadguix-patches-c7797fd49ea5c6c69bcc8547922b112d4cf488cc.tar
guix-patches-c7797fd49ea5c6c69bcc8547922b112d4cf488cc.tar.gz
gnu: Add trytond-sale-stock-quantity.
* gnu/packages/tryton.scm (trytond-sale-stock-quantity): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 67937a0457..e03f86f25a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3505,6 +3505,35 @@ line is over shipped more than the tolerance percentage, then a warning is
raised.")
(license license:gpl3+)))
+(define-public trytond-sale-stock-quantity
+ (package
+ (name "trytond-sale-stock-quantity")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_sale_stock_quantity" version))
+ (sha256
+ (base32 "0xi79nmizly3hfc1ppcid622nvby50524jflisfvmjb651ixpfl8"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "sale_stock_quantity"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-stock-supply" ,trytond-stock-supply)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)
+ ("trytond-sale" ,trytond-sale)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-sale-stock-quantity")
+ (synopsis "Tryton module to add stock warning on sale")
+ (description "The @emph{Sale Stock Quantity} Tryton module checks the
+stock quantity of the products when quoting a sale. The check will warn the
+user if the forecast quantity at the sale date (and further dates until next
+supply) is lower than the quantity sold by considering other sales and the
+stock forecasts.")
+ (license license:gpl3+)))
+
(define-public trytond-stock
(package
(name "trytond-stock")