summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:55 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:34 +0200
commitb9538dc207424f60c0472bc9bfb684f3a7411961 (patch)
tree71232ee829f792366eb12f2b7e3cb436a8cee8a3 /gnu/packages/tryton.scm
parentda2be8d5380acd16b92bfb52c622282d66439e97 (diff)
downloadguix-patches-b9538dc207424f60c0472bc9bfb684f3a7411961.tar
guix-patches-b9538dc207424f60c0472bc9bfb684f3a7411961.tar.gz
gnu: Add trytond-stock-shipment-measurements.
* gnu/packages/tryton.scm (trytond-stock-shipment-measurements): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index ad39f89227..e9f08305dd 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4150,6 +4150,34 @@ cost on the outgoing moves which is calculated from the carrier purchase
price. This cost is added to the product margin reports.")
(license license:gpl3+)))
+(define-public trytond-stock-shipment-measurements
+ (package
+ (name "trytond-stock-shipment-measurements")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_shipment_measurements" version))
+ (sha256
+ (base32 "1h9ijs7yc0013w7cwa4i7ny3dndbgycxxpkai7qw0ygqf9ajmh8c"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_shipment_measurements"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-stock-package" ,trytond-stock-package)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)
+ ("trytond-product-measurements" ,trytond-product-measurements)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page
+ "https://docs.tryton.org/projects/modules-stock-shipment-measurements")
+ (synopsis "Tryton module to add measurements to shipment")
+ (description "The @emph{Stock Shipment Measurements} Tryton module adds
+weight and volume on shipments and packages. They are computed using the
+measurement and the quantity of their moves.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-supply
(package
(name "trytond-stock-supply")