summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:34 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:31 +0200
commita948453c9f5a36b4891bad69e7133211b0c7320d (patch)
treea6698cf85dff349b00f9510958f4e7eec8ac9559 /gnu/packages/tryton.scm
parent55d1a0ab508988ae98f15c58672dcd25aae42c0d (diff)
downloadguix-patches-a948453c9f5a36b4891bad69e7133211b0c7320d.tar
guix-patches-a948453c9f5a36b4891bad69e7133211b0c7320d.tar.gz
gnu: Add trytond-purchase-price-list.
* gnu/packages/tryton.scm (trytond-purchase-price-list): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 935cc102cf..1c5456529a 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2786,6 +2786,32 @@ time the purchase is reset to draft.")
makes purchase to generate invoice lines instead of invoices.")
(license license:gpl3+)))
+(define-public trytond-purchase-price-list
+ (package
+ (name "trytond-purchase-price-list")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_purchase_price_list" version))
+ (sha256
+ (base32 "0y54b677dy1jpmclgxvbzs2zsypzkyvmdbx1i58j16hs24l8h0c8"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "purchase_price_list"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-account" ,trytond-account)
+ ("trytond-company" ,trytond-company)
+ ("trytond-party" ,trytond-party)
+ ("trytond-product-price-list" ,trytond-product-price-list)
+ ("trytond-purchase" ,trytond-purchase)))
+ (home-page "https://docs.tryton.org/projects/modules-purchase-price-list")
+ (synopsis "Tryton module to add price list on purchase")
+ (description "The @emph{Purchase Price List} Tryton Module allows price
+lists to be defined for suppliers.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase-request
(package
(name "trytond-purchase-request")