summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-24 19:20:17 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-25 16:00:17 +0200
commit6844d36443c46e42e9f4d159ff2f6c541494676c (patch)
tree78c3497a0d3ae2d5fa1946d078a84d1559543805 /gnu/packages/tryton.scm
parent84cca05cd7bd5602395add20a544d5418e670c3e (diff)
downloadguix-patches-6844d36443c46e42e9f4d159ff2f6c541494676c.tar
guix-patches-6844d36443c46e42e9f4d159ff2f6c541494676c.tar.gz
gnu: Add python-trytond-stock.
* gnu/packages/tryton.scm (python-trytond-stock): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8e475763ec..d88a559260 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -413,6 +413,61 @@ Template and Product.")
most of accounting needs.")
(license license:gpl3+)))
+(define-public python-trytond-stock
+ (package
+ (name "python-trytond-stock")
+ (version "5.6.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock" version))
+ (sha256
+ (base32 "13m57absscks2advpjz0mmmp6c0c4ksf9aln1brqyd0js38arw76"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (let ((runtest
+ (string-append
+ (assoc-ref %build-inputs "python-trytond")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/trytond/tests/run-tests.py")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" runtest "-m" "stock")))))))
+ (native-inputs
+ `(("python" ,python-minimal-wrapper)
+ ("python-genshi" ,python-genshi)
+ ("python-lxml" ,python-lxml)
+ ("python-magic" ,python-magic)
+ ("python-passlib" ,python-passlib)
+ ("python-polib" ,python-polib)
+ ("python-proteus" ,python-proteus)
+ ("python-relatorio" ,python-relatorio)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-wrapt" ,python-wrapt)))
+ (propagated-inputs
+ `(("python-simpleeval" ,python-simpleeval)
+ ("python-sql" ,python-sql)
+ ("python-trytond" ,python-trytond)
+ ("python-trytond-company"
+ ,python-trytond-company)
+ ("python-trytond-currency"
+ ,python-trytond-currency)
+ ("python-trytond-party" ,python-trytond-party)
+ ("python-trytond-product"
+ ,python-trytond-product)))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Tryton module for stock and inventory")
+ (description
+ "This package provides a Tryton module that defines the fundamentals for
+all stock management situations: Locations where products are stored, moves
+between these locations, shipments for product arrivals and departures and
+inventory to control and update stock levels.")
+ (license license:gpl3+)))
+
(define-public python-proteus
(package
(name "python-proteus")