summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-24 19:20:13 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-25 16:00:17 +0200
commit666489d633f9038455410f2a49c3b2ddf4de6b42 (patch)
treecc961404d38a9f7176388e0fbf6c52fd2c9477d9 /gnu/packages/tryton.scm
parent23dc957cb3200cc9e9823cd09412b5c14cd3d71f (diff)
downloadguix-patches-666489d633f9038455410f2a49c3b2ddf4de6b42.tar
guix-patches-666489d633f9038455410f2a49c3b2ddf4de6b42.tar.gz
gnu: Add python-trytond-company.
* gnu/packages/tryton.scm (python-trytond-company): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm49
1 files changed, 49 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index cd3da1eba5..a3ed09d5b8 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -263,6 +263,55 @@ addresses.")
currency and rate.")
(license license:gpl3+)))
+(define-public python-trytond-company
+ (package
+ (name "python-trytond-company")
+ (version "5.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_company" version))
+ (sha256
+ (base32 "0fa2yswfal1fbmm0ml845lm6bwcm65fln6s1xq1wqi17xqbbx44x"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (let ((runtest
+ (string-append
+ (assoc-ref %build-inputs "python-trytond")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/trytond/tests/run-tests.py")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ (invoke "python" runtest "-m" "company")))))))
+ (native-inputs
+ `(("python" ,python-minimal-wrapper)
+ ("python-dateutil" ,python-dateutil)
+ ("python-genshi" ,python-genshi)
+ ("python-lxml" ,python-lxml)
+ ("python-magic" ,python-magic)
+ ("python-passlib" ,python-passlib)
+ ("python-polib" ,python-polib)
+ ("python-proteus" ,python-proteus)
+ ("python-relatorio" ,python-relatorio)
+ ("python-sql" ,python-sql)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-wrapt" ,python-wrapt)))
+ (propagated-inputs
+ `(("python-trytond" ,python-trytond)
+ ("python-trytond-currency"
+ ,python-trytond-currency)
+ ("python-trytond-party" ,python-trytond-party)))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Tryton module with companies and employees")
+ (description
+ "This package provides a Tryton module that defines the concepts of
+company and employee and extend the user model.")
+ (license license:gpl3+)))
+
(define-public python-proteus
(package
(name "python-proteus")