summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2022-07-19 16:37:41 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-08-10 14:27:27 +0200
commit62bee0a915ca15dadfc584d7f619f546f5f1256b (patch)
tree7befc2512d88508339c5c76c723a2938b59bdb32 /gnu/packages/tryton.scm
parent0d9f15868535fbb65d4920387755005acec7f63b (diff)
downloadguix-patches-62bee0a915ca15dadfc584d7f619f546f5f1256b.tar
guix-patches-62bee0a915ca15dadfc584d7f619f546f5f1256b.tar.gz
gnu: Add trytond-web-shop-shopify.
* gnu/packages/tryton.scm (trytond-web-shop-shopify): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 8385c5fd5f..8e561cad45 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4508,6 +4508,39 @@ user for a period of time only.")
configuration of an online web shop.")
(license license:gpl3+)))
+(define-public trytond-web-shop-shopify
+ (package
+ (name "trytond-web-shop-shopify")
+ (version "6.2.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_web_shop_shopify" version))
+ (sha256
+ (base32 "1nd2wnzr6cibqcsidk0k98iy4vs7dy7crhld60wkbza8pgc23hc4"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "trytond_web_shop_shopify"))
+ (native-inputs (%standard-trytond-native-inputs))
+ (propagated-inputs (list python-dateutil
+ python-pyactiveresource
+ python-shopifyapi
+ python-sql
+ trytond
+ trytond-account-payment
+ trytond-currency
+ trytond-party
+ trytond-product
+ trytond-product-attribute
+ trytond-sale
+ trytond-sale-payment
+ trytond-stock
+ trytond-web-shop))
+ (home-page "https://docs.tryton.org/projects/modules-web-shop-shopify")
+ (synopsis "Integrate Tryton with Shopify")
+ (description "The @emph{Web Shop Shopify} Tryton module provides a way to
+manage @emph{Shopify} stores. It uploads products, variants and collections
+to Shopify, and downloads orders, transactions and creates fulfilments.")
+ (license license:gpl3+)))
+
(define-public trytond-web-shop-vue-storefront
(package
(name "trytond-web-shop-vue-storefront")