summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:48 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:33 +0200
commit5d191a04f465b443f3306a4f03abe8b339ffa1b8 (patch)
treea38b2d41b860c67e5b3462f121bcbb59bf114d4a /gnu/packages/tryton.scm
parent6aa1127f88fee3f90a9471670c5fba6203ab4a9d (diff)
downloadguix-patches-5d191a04f465b443f3306a4f03abe8b339ffa1b8.tar
guix-patches-5d191a04f465b443f3306a4f03abe8b339ffa1b8.tar.gz
gnu: Add trytond-stock-assign-manual.
* gnu/packages/tryton.scm (trytond-stock-assign-manual): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 51857aaff3..dad11f66b5 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -3706,6 +3706,31 @@ inventory to control and update stock levels.")
(define-public python-trytond-stock
(deprecated-package "python-trytond-stock" trytond-stock))
+(define-public trytond-stock-assign-manual
+ (package
+ (name "trytond-stock-assign-manual")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_stock_assign_manual" version))
+ (sha256
+ (base32 "0106x21ncxiyd4jsbdapmf6gfix6infjf59807j2lqmrblb3z25f"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "stock_assign_manual"))
+ (native-inputs
+ `(,@%standard-trytond-native-inputs
+ ("trytond-production" ,trytond-production)))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-stock" ,trytond-stock)))
+ (home-page "https://docs.tryton.org/projects/modules-stock-assign-manual")
+ (synopsis "Tryton module to assign manually stock move")
+ (description "The @emph{Stock Assign Manual} Tryton module adds a wizard
+on shipments and production that allows you to decide from which precise
+location to pick products.")
+ (license license:gpl3+)))
+
(define-public trytond-stock-lot
(package
(name "trytond-stock-lot")