summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:24 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:29 +0200
commit43304c20176b8372a6f16ef5736453acd1cb74de (patch)
tree05dd2d206a5a412286ab6d2cd4955c05dd614733 /gnu/packages/tryton.scm
parent633e2aa7e4893e8a6614063c74e42c174d1cae7d (diff)
downloadguix-patches-43304c20176b8372a6f16ef5736453acd1cb74de.tar
guix-patches-43304c20176b8372a6f16ef5736453acd1cb74de.tar.gz
gnu: Add trytond-product-attribute.
* gnu/packages/tryton.scm (trytond-product-attribute): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index d027477952..7d8d015077 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -2125,6 +2125,28 @@ Template and Product.")
(define-public python-trytond-product
(deprecated-package "python-trytond-product" trytond-product))
+(define-public trytond-product-attribute
+ (package
+ (name "trytond-product-attribute")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_product_attribute" version))
+ (sha256
+ (base32 "0brvwvm3q2ik4vjb9cwd6jxddrmpp2vcafw8k675gy0xbbp1ddik"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "product_attribute"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-product" ,trytond-product)))
+ (home-page "https://docs.tryton.org/projects/modules-product-attribute")
+ (synopsis "Tryton module with product attributes")
+ (description "The @emph{Product Attribute} Tryton module defines the
+models `Attribute` and `Attribute Set` for products.")
+ (license license:gpl3+)))
+
(define-public trytond-purchase
(package
(name "trytond-purchase")