summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2020-08-26 10:51:53 -0300
committerMathieu Othacehe <othacehe@gnu.org>2020-08-27 10:09:10 +0200
commit261b5cced5a6bfbf30cdaa234d3cc6a2dc864fb9 (patch)
tree74a42bc6fc7697d7c62b4cd89ad672d267ed35d5 /gnu/packages/tryton.scm
parent51459b8f2c2c90bbca7d2bc2755c263b0c5d6b4c (diff)
downloadguix-patches-261b5cced5a6bfbf30cdaa234d3cc6a2dc864fb9.tar
guix-patches-261b5cced5a6bfbf30cdaa234d3cc6a2dc864fb9.tar.gz
gnu: Add python-trytond-purchase-request.
* gnu/packages/tryton.scm (python-trytond-purchase-request): New variable. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 2aed9da8f6..ae6de75ced 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -795,6 +795,59 @@ average price of the posted invoice lines that are linked to it.")
"This package provides a Tryton module that defines the Purchase model.")
(license license:gpl3+)))
+(define-public python-trytond-purchase-request
+ (package
+ (name "python-trytond-purchase-request")
+ (version "5.6.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_purchase_request" version))
+ (sha256
+ (base32 "15r1x3jzr83rna1vfpans277785dpmgjr7989icav602nkyhhx0x"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (replace 'check
+ (let ((runtest
+ (string-append
+ (assoc-ref %build-inputs "python-trytond")
+ "/lib/python"
+ ,(version-major+minor (package-version python))
+ "/site-packages/trytond/tests/run-tests.py")))
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (add-installed-pythonpath inputs outputs)
+ ;; Doctest 'scenario_purchase_request.rst' fails.
+ (invoke "python" runtest
+ "-m" "purchase_request" "--no-doctest")))))))
+ (native-inputs
+ `(("python" ,python-minimal-wrapper)
+ ("python-dateutil" ,python-dateutil)
+ ("python-genshi" ,python-genshi)
+ ("python-lxml" ,python-lxml)
+ ("python-magic" ,python-magic)
+ ("python-passlib" ,python-passlib)
+ ("python-polib" ,python-polib)
+ ("python-proteus" ,python-proteus)
+ ("python-relatorio" ,python-relatorio)
+ ("python-sql" ,python-sql)
+ ("python-werkzeug" ,python-werkzeug)
+ ("python-wrapt" ,python-wrapt)))
+ (propagated-inputs
+ `(("python-trytond" ,python-trytond)
+ ("python-trytond-product"
+ ,python-trytond-product)
+ ("python-trytond-purchase"
+ ,python-trytond-purchase)))
+ (home-page "https://www.tryton.org/")
+ (synopsis "Tryton module for purchase requests")
+ (description
+ "This package provides a Tryton module that introduces the concept of
+Purchase Requests which are central points to collect purchase requests
+generated by other process from Tryton.")
+ (license license:gpl3+)))
+
(define-public python-proteus
(package
(name "python-proteus")