summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2021-08-27 15:09:56 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-09-21 21:00:35 +0200
commit25ed927453c93de233dc975bb26572e64cc0cee7 (patch)
tree43ce59abd49ef32883e3b77b603a3bf24be2b64a /gnu/packages/tryton.scm
parent2788e17484543fe1cc172eb4ac9627941be68e93 (diff)
downloadguix-patches-25ed927453c93de233dc975bb26572e64cc0cee7.tar
guix-patches-25ed927453c93de233dc975bb26572e64cc0cee7.tar.gz
gnu: Add trytond-timesheet.
* gnu/packages/tryton.scm (trytond-timesheet): New variable.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index 9f29d62072..6740cd2da0 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -4306,3 +4306,28 @@ forecast into account to compute purchase requests.")
(description "The @emph{Stock Supply Production} module adds automatic
supply mechanisms via production request.")
(license license:gpl3+)))
+
+(define-public trytond-timesheet
+ (package
+ (name "trytond-timesheet")
+ (version "6.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "trytond_timesheet" version))
+ (sha256
+ (base32 "0airh5jvcdjbkb71p684dr5qgsnpam2hhmq6gswclgnx3nd1lz6a"))))
+ (build-system python-build-system)
+ (arguments (tryton-arguments "timesheet"))
+ (native-inputs `(,@%standard-trytond-native-inputs))
+ (propagated-inputs
+ `(("trytond" ,trytond)
+ ("trytond-company" ,trytond-company)
+ ("trytond-company-work-time" ,trytond-company-work-time)))
+ (home-page "https://docs.tryton.org/projects/modules-timesheet")
+ (synopsis "Tryton module with timesheets")
+ (description "The @emph{Timesheet} Tryton module allows to track the time
+spent by employees on various works. This module also comes with several
+reports that show the time spent by employees on works following various time
+periods.")
+ (license license:gpl3+)))