summaryrefslogtreecommitdiff
path: root/gnu/packages/tryton.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-11-21 22:25:30 +0100
committerLudovic Courtès <ludo@gnu.org>2021-11-21 23:01:15 +0100
commit1b1e9b51f4ea2d691decb438df1c9faf64ef1ac2 (patch)
tree8b5c63531761bad3b1ada76ca3cbd78172c4c2e7 /gnu/packages/tryton.scm
parent248199863cbdc3e13d5aa62fad6fe1c6a027b149 (diff)
downloadguix-patches-1b1e9b51f4ea2d691decb438df1c9faf64ef1ac2.tar
guix-patches-1b1e9b51f4ea2d691decb438df1c9faf64ef1ac2.tar.gz
gnu: trytond: Build against python-werkzeug 1.0.
* gnu/packages/tryton.scm (trytond)[propagated-inputs]: Replace PYTHON-WERKZEUG by PYTHON-WERKZEUG-1.0. * gnu/packages/tryton.scm (%standard-trytond-native-inputs): Likewise.
Diffstat (limited to 'gnu/packages/tryton.scm')
-rw-r--r--gnu/packages/tryton.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/tryton.scm b/gnu/packages/tryton.scm
index c1275edd22..5afd49a88d 100644
--- a/gnu/packages/tryton.scm
+++ b/gnu/packages/tryton.scm
@@ -60,7 +60,7 @@
("python-psycopg2" ,python-psycopg2)
("python-relatorio" ,python-relatorio)
("python-sql" ,python-sql)
- ("python-werkzeug" ,python-werkzeug)
+ ("python-werkzeug" ,python-werkzeug-1.0) ;setup.py requires werkzeug<2
("python-wrapt" ,python-wrapt)))
(native-inputs
`(("python-mock" ,python-mock)
@@ -183,7 +183,7 @@ the build system."
("python-proteus" ,python-proteus)
("python-relatorio" ,python-relatorio)
("python-sql" ,python-sql)
- ("python-werkzeug" ,python-werkzeug)
+ ("python-werkzeug" ,python-werkzeug-1.0)
("python-wrapt" ,python-wrapt)))
(define-public trytond-account