summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-19 02:00:00 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-07-17 02:00:12 +0200
commitc2aecd6738860450c995d77fa1fa240ede2ab46d (patch)
treead1bdd5894bd0ed739d0b08ae6922dff4fdf7cda /gnu/packages/toys.scm
parent023b3ca6e5c45409b5622098cf06ea9c61f3d5b3 (diff)
downloadguix-patches-c2aecd6738860450c995d77fa1fa240ede2ab46d.tar
guix-patches-c2aecd6738860450c995d77fa1fa240ede2ab46d.tar.gz
gnu: lolcat: Move to (gnu packages toys).
As fun as this is, the gameplay is disappointing. Also add a missing 2019 copyright for Liliana Marie. * gnu/packages/games.scm (lolcat): Move from here… * gnu/packages/toys.scm (lolcat): …to here.
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 4fa6966ca9..fb2f367490 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2017, 2018, 2020–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Jesse Gibbons <jgibbons2357+guix@gmail.com>
;;; Copyright © 2019, 2020, 2021 Timotej Lazar <timotej.lazar@araneo.si>
+;;; Copyright © 2019 Liliana Marie Prikler <liliana.prikler@gmail.com>
;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;;
@@ -38,6 +39,46 @@
#:use-module (guix packages)
#:use-module (guix utils))
+(define-public lolcat
+ (let ((commit "35dca3d0a381496d7195cd78f5b24aa7b62f2154")
+ (revision "0"))
+ (package
+ (name "lolcat")
+ (version (git-version "1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jaseg/lolcat")
+ (commit commit)))
+ (sha256
+ (base32
+ "0jjbkqcc2ikjxd1xgdyv4rb0vsw218181h89f2ywg29ffs3ypd8g"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no check target
+ #:make-flags
+ (list ,(string-append "CC=" (cc-for-target)))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'bootstrap)
+ (delete 'configure)
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (dest (string-append out "/bin")))
+ (mkdir-p dest)
+ (install-file "lolcat" dest)
+ (install-file "censor" dest)
+ #t))))))
+ (home-page "https://github.com/jaseg/lolcat")
+ (synopsis "Rainbow coloring effect for text console display")
+ (description "@command{lolcat} concatenates files and streams like
+regular @command{cat}, but it also adds terminal escape codes between
+characters and lines resulting in a rainbow effect.")
+ (license license:wtfpl2))))
+
(define-public oneko
(package
(name "oneko")