summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/toys.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar
guix-patches-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running: ./pre-inst-env guix style without any additional argument.
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm19
1 files changed, 8 insertions, 11 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 52a4d0bb15..80928474aa 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -61,10 +61,9 @@
#t))))
(build-system gnu-build-system)
(native-inputs
- `(("imake" ,imake)))
+ (list imake))
(inputs
- `(("libx11" ,libx11)
- ("libxext" ,libxext)))
+ (list libx11 libxext))
(arguments
`(#:tests? #f ; no tests
#:phases
@@ -113,7 +112,7 @@ mouse pointer around the screen while you work.")
(base32 "1zrfd71zx2px2xpapg45s8xvi81xii63yl0h60q72j71zh4sif8b"))))
(build-system gnu-build-system)
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(arguments
`(#:phases
(modify-phases %standard-phases
@@ -178,10 +177,9 @@ typing @command{sl} instead of @command{ls}.")
#t)))
#:tests? #f)) ; no test suite
(native-inputs
- `(("bison" ,bison)
- ("flex" ,flex)))
+ (list bison flex))
(inputs
- `(("perl" ,perl)))
+ (list perl))
(home-page "https://joeyh.name/code/filters/")
(synopsis "Various amusing text filters")
(description
@@ -257,7 +255,7 @@ The GNU project hosts a similar collection of filters, the GNU talkfilters.")
("libxt" ,libxt)
("libxxml2" ,libxml2)))
(native-inputs
- `(("pkg-config" ,pkg-config)))
+ (list pkg-config))
(home-page "https://www.ratrabbit.nl/ratrabbit/content/xsnow/introduction")
(synopsis "Let it snow on the desktop")
(description "@code{Xsnow} animates snowfall and Santa with reindeer on
@@ -329,10 +327,9 @@ of the Nyan Cat / Poptart Cat animation.")
,(package-version this-package))))
(install-file "README.md" doc)))))))
(native-inputs
- `(("pkg-config" ,pkg-config)
- ("scdoc" ,scdoc)))
+ (list pkg-config scdoc))
(inputs
- `(("ncurses" ,ncurses)))
+ (list ncurses))
(home-page "https://gitlab.com/jallbrit/cbonsai")
(synopsis "Grow bonsai trees in a terminal")
(description "Cbonsai is a bonsai tree generator using ASCII art. It