summaryrefslogtreecommitdiff
path: root/gnu/packages/toys.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 16:52:18 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2020-10-16 17:16:01 +0200
commit544672029213ae5ec79e2083a50e0e83edff18a6 (patch)
tree4ed2a72bcfc8a85296ce53914e63633cada7cdc5 /gnu/packages/toys.scm
parentdae2ac513d1e2eb242240ecd1551a700d20f54f5 (diff)
downloadguix-patches-544672029213ae5ec79e2083a50e0e83edff18a6.tar
guix-patches-544672029213ae5ec79e2083a50e0e83edff18a6.tar.gz
gnu: filters: Fix bogus use of DESTDIR.
* gnu/packages/toys.scm (filters)[arguments]: Set and respect the standard prefix variable.
Diffstat (limited to 'gnu/packages/toys.scm')
-rw-r--r--gnu/packages/toys.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/toys.scm b/gnu/packages/toys.scm
index 1ce3cde617..6387e84a3d 100644
--- a/gnu/packages/toys.scm
+++ b/gnu/packages/toys.scm
@@ -101,17 +101,17 @@ typing @command{sl} instead of @command{ls}.")
(arguments
`(#:make-flags
(list (string-append "CC=" ,(cc-for-target))
- (string-append "DESTDIR=" %output))
+ (string-append "prefix=" (assoc-ref %outputs "out")))
#:phases
(modify-phases %standard-phases
(delete 'configure)
- (add-after 'unpack 'fix-install-directories
+ (add-after 'unpack 'respect-prefix
(lambda _
(substitute* "Makefile"
(("/usr/games")
- "/bin/")
- (("/usr/share/")
- "/share/"))
+ "$(prefix)/bin/")
+ (("/usr")
+ "$(prefix)"))
#t)))
#:tests? #f)) ; no test suite
(native-inputs